Unable to install IJulia after upgrading to version 1.9

Trying to install IJulia, but unable to after upgrading to version 1.9


Any ideas?

Can you add any other packages? Have you tried adding it to an empty environment?

To me the message sounds like the resolve of the environment wants some package Curry that is not found, though when I try to install IJulia it works and I don’t need any Curry. It makes me think you might have some existing things in the @1.9 environment that is the cause of this, and IJulia is just the reason for the new resolve that makes it visible.

Maybe check the status of your env to see what is there?

Installing IJulia in an empty env looks like this for me

(@v1.9) pkg> activate --temp
  Activating new project at `/tmp/jl_0c5m6T`

(jl_0c5m6T) pkg> add IJulia
    Updating registry at `~/.julia/registries/General.toml`
   Resolving package versions...
   Installed Parsers ─ v2.5.9
    Updating `/tmp/jl_0c5m6T/Project.toml`
  [7073ff75] + IJulia v1.24.0
    Updating `/tmp/jl_0c5m6T/Manifest.toml`
  [8f4d0f93] + Conda v1.8.0
  [7073ff75] + IJulia v1.24.0
  [692b3bcd] + JLLWrappers v1.4.1
  [682c06a0] + JSON v0.21.4
  [739be429] + MbedTLS v1.1.7
  [69de0a69] + Parsers v2.5.9
  [aea7be01] + PrecompileTools v1.1.1
  [21216c6a] + Preferences v1.4.0
  [b85f4697] + SoftGlobalScope v1.1.0
  [81def892] + VersionParsing v1.3.0
  [c2297ded] + ZMQ v1.2.2
  [8f1865be] + ZeroMQ_jll v4.3.4+0
  [a9144af2] + libsodium_jll v1.0.20+0
  [0dad84c5] + ArgTools v1.1.1
  [56f22d72] + Artifacts
  [2a0f44e3] + Base64
  [ade2ca70] + Dates
  [f43a241f] + Downloads v1.6.0
  [7b1f6079] + FileWatching
  [b77e0a4c] + InteractiveUtils
  [b27032c2] + LibCURL v0.6.3
  [76f85450] + LibGit2
  [8f399da3] + Libdl
  [56ddb016] + Logging
  [d6f4376e] + Markdown
  [a63ad114] + Mmap
  [ca575930] + NetworkOptions v1.2.0
  [44cfe95a] + Pkg v1.9.0
  [de0858da] + Printf
  [3fa0cd96] + REPL
  [9a3f8284] + Random
  [ea8e919c] + SHA v0.7.0
  [9e88b42a] + Serialization
  [6462fe0b] + Sockets
  [fa267f1f] + TOML v1.0.3
  [a4e569a6] + Tar v1.10.0
  [8dfed614] + Test
  [cf7118a7] + UUIDs
  [4ec0a83e] + Unicode
  [deac9b47] + LibCURL_jll v7.84.0+0
  [29816b5a] + LibSSH2_jll v1.10.2+0
  [c8ffd9c3] + MbedTLS_jll v2.28.2+0
  [14a3606d] + MozillaCACerts_jll v2022.10.11
  [83775a58] + Zlib_jll v1.2.13+0
  [8e850ede] + nghttp2_jll v1.48.0+0
  [3f19e933] + p7zip_jll v17.4.0+0
Precompiling project...
  4 dependencies successfully precompiled in 33 seconds. 12 already precompiled.
1 Like

hello albheim,

this is what I get when I follow your procedure:



I get no errors. Now, what to do next?

  1. how do I remove the new temp environment that I have created?

  2. what should I do in my real environment?

thank you for your support

Temporary environments auto-destruct when you exit Julia, that’s why they’re called temporary.

What you need to do in your default environment depends on what is wrong with is, hence why Albin recommended to check it’s status.

Without any additional information I assume this is a case of installing loads of packages in the default environment (as opposed to project specific environments), which after a while makes it very likely that issues occur.

1 Like

hello nilshg,

I exited Julia and I suppose the temp environment has been removed.

I am still stuck.

The Curry package is in the status.

  1. The Curry package is in the status.
  2. However, Curry is not registered

I’m lost, unable to continue.

Should I uninstall Julia altogether and re-install it again?

What happens if you try to install IJulia after you removed Curry? I would guess it could work now.


IJulia is already installed. Now I try to execute it.

It seems I cannot execute IJulia. I’m sorry to disturb you.

Not sure why that happens, seems like it is installing Conda.jl to get jupyter, but crashes while installing the miniconda backend.

Do you already have a Jupyter installation on your computer? Then you could try to tell IJulia to use that as mentioned in

Conda is already installed in my PC.

Nevertheless, in order to make clean, I removed it and installed it again.

Same problem:

The only thing I do not know exactly how to do is how to add JUPYTER to the PATH of the Jupyter program.

I am a bit discouraged, and am starting to think that I need a drastic uninstall/install of both Julia and Jypyter. Would this solve the problem?

Thank you for your support

You can force it to use a specific jupyter installation by setting ENV["JUPYTER"] to the path of the jupyter program before Pkg.add, or before running Pkg.build("IJulia"); your preference is remembered on subsequent updates.

So running something like

ENV["JUPYTER"] = joinpath(homedir(), "path", "to", "jupyter")

and then either adding or rebuilding IJulia seems like one way to go.

I’m not sure a reinstall would help, but I don’t know. I don’t have the same problem on my computer so it is hard for me to debug.

1 Like

hello albheim,

your statement for the REPL:

ENV["JUPYTER"] = joinpath(homedir(), "path", "to", "jupyter")

… has worked, and I now have access to Julia from within Jupyter. Tnak you very much.

Without your proposal for statement to run, which is not at all clear (is not evident) from the documentation, I would never have succeeded. So thanks again.

1 Like