Trouble with IJulia after upgrade to 1.3.1

After switching to Julia 1.3.1 IJulia does not work any more on my system. In the output below you can see what happened.

The installation of Jupyter went well. But the call notebook() shows some info about the environment and then immediately returns. No browser opens.

  | | |_| | | | (_| |  |  Version 1.3.1 (2019-12-30)
 _/ |\__'_|_|_|\__'_|  |  Official release  
|__/                   |

julia> using IJulia
[ Info: Precompiling IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a]

julia> notebook()
install Jupyter via Conda, y/n? [y]: y
[ Info: Downloading miniconda installer ...
[ Info: Installing miniconda ...

… many packages downloaded and installed
… seemingly all went fine
But then:

julia> notebook()

Info: running setenv(`'C:\Users\Home\.julia\conda\3\Scripts\jupyter.exe' notebook`,
... and many more ... ])
Process(setenv(`'C:\Users\...) ProcessExited(1))


See my advice in another thread.

1 Like

Thanks! I have tried that. Now the browser opens.

But in the list of kernels 1.3.1 does not show up.

Then I tried with 1.4.0-rc1. This time the kernel is in the list but immediately dies.

What exactly did you try that fixed the problem? (I suggested 3 things in the link.)

Try build IJulia — this re-installs the kernel file (which maybe you deleted in an earlier attempt to fix things?)

I tried one thing after the other. So it was the third step.

I’ve done this before, but I do it again … and something new:

| | || | | | (| | | Version 1.3.1 (2019-12-30)
/ |_|||_’_| | Official release

julia> using Pkg

Building Conda ──→ C:\Users\Home\.julia\packages\Conda\OIHWB\deps\build.log
Building MbedTLS → C:\Users\Home\.julia\packages\MbedTLS\a1JFn\deps\build.log
Building IJulia ─→ C:\Users\Home\.julia\packages\IJulia\yLI42\deps\build.log

Do you see this little unexplained ‘false’? I haven’t seen it before.
Perhaps I should add that I am on Windows 10.

And now 1.3.1 shows up in the list of kernels, but the behavior is the same: no connection to the nb-server could be established.

It works fine for me. Maybe you have firewall software installed that is blocking the Jupyter web server? Does a Python notebook work?

Python works, C# works.
And then there’s the timing: it worked before with Julia, only with the installation of 1.3.1 it stopped.

When executing jupyter-notebook.exe directly I get the error below.

[I 07:05:51.941 NotebookApp] Serving notebooks from local directory: 
[I 07:05:51.941 NotebookApp] The Jupyter Notebook is running at:
[I 07:05:51.941 NotebookApp] http://localhost:8888/?token=15
    To access the notebook, open this file in a browser:
[I 07:06:09.445 NotebookApp] Creating new notebook in
[I 07:06:11.453 NotebookApp] Kernel started: ba768ed8-aa83-45d8-85d5-d7a0e18a10c3
[W 07:06:11.525 NotebookApp] 404 GET /nbextensions/widgets/notebook/js/extension.js? 
v=20200211070550 (::1) 60.00ms 
ERROR: LoadError: ArgumentError: Package IJulia not found in current path:
- Run `import Pkg; Pkg.add("IJulia")` to install the IJulia package.
 [1] require(::Module, ::Symbol) at .\loading.jl:887
 [2] include at .\boot.jl:328 [inlined]
 [3] include_relative(::Module, ::String) at .\loading.jl:1105
 [4] include(::Module, ::String) at .\Base.jl:31
 [5] exec_options(::Base.JLOptions) at .\client.jl:287
 [6] _start() at .\client.jl:460
in expression starting at C:\Users\Home\.julia\packages\IJulia\yLI42\src\kernel.jl:1
[I 07:06:17.420 NotebookApp] KernelRestarter: restarting kernel (1/5), keep random ports

Run import Pkg; Pkg.add("IJulia") to install the IJulia package.
This error-message is absurd and contradictory. Look at the line:
in expression starting at C:\Users\Home.julia\packages\IJulia\yLI42\src\kernel.jl:1