Trouble running IJulia (could not open file .julia/packages/IJulia/IDNmS ...)


I recently updated IJulia and am now having trouble starting the kernel from jupyter notebook. From the Terminal, I run jupyter notebook, which opens up jupyter in my browser.

(base) ➜  Non-markovian-simulation- git:(package-sacha) ✗ jupyter notebook
[I 15:28:42.515 NotebookApp] JupyterLab extension loaded from /Users/sachagreenfield/opt/anaconda3/lib/python3.7/site-packages/jupyterlab
[I 15:28:42.515 NotebookApp] JupyterLab application directory is /Users/sachagreenfield/opt/anaconda3/share/jupyter/lab
[I 15:28:42.522 NotebookApp] Serving notebooks from local directory: /Users/sachagreenfield/Desktop/GitHub/Non-markovian-simulation-
[I 15:28:42.522 NotebookApp] The Jupyter Notebook is running at:
[I 15:28:42.522 NotebookApp] http://localhost:8888/?token=123a0e08e9b8049d161f1e6b490300c1f04d049849f34123
[I 15:28:42.522 NotebookApp]  or
[I 15:28:42.522 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).

However, when I open a notebook (not yet executing any block), I get the following error messages:

[I 15:29:02.842 NotebookApp] Saving file at /notebooks/Qubit - resonator/Qubit - resonator basic example.ipynb
[I 15:29:07.906 NotebookApp] Kernel started: e2d07856-f2fa-4ec8-962e-bb62985a5c68
ERROR: could not open file /Users/sachagreenfield/.julia/packages/IJulia/IDNmS/src/kernel.jl
 [1] include(::Module, ::String) at ./Base.jl:377
 [2] exec_options(::Base.JLOptions) at ./client.jl:288
 [3] _start() at ./client.jl:484
[I 15:29:13.847 NotebookApp] KernelRestarter: restarting kernel (1/5), keep random ports

The kernel tries to restart 4 more times and then gives up, saying

[W 15:29:25.902 NotebookApp] KernelRestarter: restart failed
[W 15:29:25.902 NotebookApp] Kernel e2d07856-f2fa-4ec8-962e-bb62985a5c68 died, removing from map.
[W 15:30:08.331 NotebookApp] Timeout waiting for kernel_info reply from e2d07856-f2fa-4ec8-962e-bb62985a5c68
[E 15:30:08.334 NotebookApp] Error opening stream: HTTP 404: Not Found (Kernel does not exist: e2d07856-f2fa-4ec8-962e-bb62985a5c68)
[W 15:30:12.562 NotebookApp] 404 GET /api/kernels/e2d07856-f2fa-4ec8-962e-bb62985a5c68/channels?session_id=e38ad5314f5a412aac3acf3a7f71b698 (::1): Kernel does not exist: e2d07856-f2fa-4ec8-962e-bb62985a5c68
[W 15:30:12.577 NotebookApp] 404 GET /api/kernels/e2d07856-f2fa-4ec8-962e-bb62985a5c68/channels?session_id=e38ad5314f5a412aac3acf3a7f71b698 (::1) 19.56ms referer=None
[W 15:30:16.139 NotebookApp] Replacing stale connection: e2d07856-f2fa-4ec8-962e-bb62985a5c68:e38ad5314f5a412aac3acf3a7f71b698

I’ve tried re-adding IJulia and running the tests in “IJulia/e8kqU/test”. I also tried to look for the folder it is looking for – “.julia/packages/IJulia/IDNmS” but I could not see that in the IJulia folder – only e8kqU. I also tried adding IDNmS as a package, but I get the following error, possibly because I’m not sure how to tell it where IDNmS belongs:

julia> Pkg.add("IDNmS")
    Updating registry at `~/.julia/registries/General`
ERROR: The following package names could not be resolved:
 * IDNmS (not found in project, manifest or registry)

I have used IJulia in the past just fine. Any help would be appreciated!