Trouble uninstalling Julia 0.4.5 from Windows 10 machine

question

#1

I’ve tried wiping my Julia installation by deleting the Julia folder containing all install files from AppData/Local/Julia-0.4.5.

I’ve tried installing 0.6.4 (not the v1 release because I’m developing code that is in 0.6.4) but when I call julia from the Windows 10 command prompt it opens the 0.4.5 REPL even though I’ve uninstalled it. I’ve used ‘locate julia’ and found nothing before installing Julia 0.6.4.

Do you know how I can remove all files from 0.4.5 from my computer? Or how I can check to see the path that ‘julia’ command pulls from when I run in the command prompt?


#2

From the Windows cmd

where julia

#3

Whoops I misspoke. I’m using the Linux bash shell for Windows 10 - not the command prompt (cmd). My network admin has disabled Windows cmd on my machine. where julia isn’t recognized on the bash shell.


#4

Then

which julia

#5

Ah ha! I see

/usr/bin/julia

Should I delete this?

When I view it it is mostly symbols but I see the following including a 0.4.5 error message:

parser error:
^@+vhqFfH:e:E:P:L:J:C:ip:Ob:^@unknown option -%c^@unknown option %s^@0.4.5^@julia version %s
^@%s%s^@auto^@user^@none^@error^@ieee^@fast^@version^@help^@quiet^@home^@eval^@print^@post-boot^@load^@ ^@^@^@WARNING: jl_errorexception_type not defined; any errors will be fatal. ^@option `-%c/--%s` is missing an argument^@^@^@^@^@^@^@^@option `--%s` is missing an argument^@^@^@^@j
This is a bug, please report it.^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@P���^P���^P���^P���$
-h, --help Print this message

-J, --sysimage Start up with the given system image file
–precompiled={yes|no} Use precompiled code from system image if available
-H, --home Set location of julia executable
–startup-file={yes|no} Load ~/.juliarc.jl
-f, --no-startup Don’t load ~/.juliarc (deprecated, use --startup-file=no)
-F Load ~/.juliarc (deprecated, use --startup-file=yes)
–handle-signals={yes|no} Enable or disable Julia’s default signal handlers


#6

Not sure on how to uninstall on linux. There are also probably some libs in /usr/lib or alike.