Uninstalling julia completely

I am trying to uninstall and then reinstall julia entirely as I had issues similar to this one using Atom/Juno.

I followed the steps I could find online, as described in the second section here. I also tried to find related files and deleted the manually.

However, while I do the steps again it tells me that ‘no package julia is installed’, when I type ‘julia’ in a terminal, it still starts the REPL. I noticed that it starts an old version of julia, 1.0.4. (Though it cannot find some basic packages that were previously installed, such as Plots).

How can I make sure that everything is uninstalled so that I can try to freshly reinstall julia and hopefully not have the same problems?

1 Like

What is your platform? On Windows I can locate the various versions under AppData, and remove them manually if need be.

1 Like

You can go to Juno settings and see the julia.exe path (on Windows). Then uninstall from there. Please keep in mind that all packages are usually under C:/Users/username/.julia. So if you really want a clean setup, you need to delete that .julia folder.
EDIT: now I saw you said terminal. You can type where julia if you are on Windows to get the path to the executable.

In terminal
‘rm -rf ~/.julia’

I think the OP was complaining about extraneous executables of Julia.
On Windows these are typically in C:\Users\USERNAME\AppData\Local\Programs\Julia\Julia-1.4.0, or C:\Users\USERNAME\AppData\Local\Programs\Julia 1.5.0-DEV

1 Like

Hey guys, I’m on Ubuntu 18. I run this command as suggested rm -rf ~/.julia but still I have the same problem. (I already ran that before).Selection_389

Hi,

in ~./Julia/ directory are config files and installed packages.

Julia installation is in different directory. Look into you PATH in .bashrc.
For example, I have Julia installed (unpacked) directly in the home directory ~/julia-1.3.1

Use command:

which julia

Try which julia in the terminal.

1 Like

Indeed, this worked. It was in /snap/bin/julia. Thanks!