Trouble registering package

package
#1

So, I’ve tried registering SeisIO.jl many times now over the course of 2+ years, including the new system that will take effect tomorrow, and it never seems to get registered. I checked for naming conflicts in the past and found none (though there’s now a newer package on Github, unregistered with no releases, that uses the same name). How and where can I check the registration status in the current (new) system? How long should registration take, and what should I do if I don’t see that happen?

0 Likes

Switching package registration systems soon
#2

I don’t see any record of any of your earlier attempts, but there is an open PR to register SeisIO here: https://github.com/JuliaLang/METADATA.jl/pull/22347 You can see from the test output that there is an issue with the uuid you’ve chosen, which is why the PR is failing its tests: https://travis-ci.org/JuliaLang/METADATA.jl/jobs/509856282#L511

(By the way, it would probably be better to split this off into its own topic so that we can keep helping you without detailing the thread)

0 Likes

#3

Looks like this was split off to a new topic. Current instructions from the output are:

ERROR: LoadError: LoadError: Tagged version 0.1.3 of SeisIO declares the package UUID to be 
"e2f1b5a8-5fbb-5d5d-94aa-e39813b81559" in its Project file, which does not match the package's 
METADATA-compatible UUID "b372bb87-02dd-52bb-bcf6-c30dd83fd342".

To fix this error, change the UUID to be "b372bb87-02dd-52bb-bcf6-c30dd83fd342" and retag.

I edited Project.toml to the compatible UUID. Will this be fixed if I do another release (i.e., increment to 0.1.4)?

0 Likes

#4

See https://github.com/attobot/attobot#updatingdeleting-a-release.

0 Likes

#5

Thank you, tkoolen. Tried the delete/rerelease approach (using the manually-corrected UUID) and now we wait. (edit) I think that worked.

0 Likes

#6

Hi, I’m having trouble with JuliaRegistrator process for IncrementalInference.jl v0.5.5 too. Thought I should at least link a description of the issue I’m having in this thread (no solution yet):

0 Likes

#7

This seems to be triggering an assertion failure in the version resolver. Not sure what’s going on there. We’ll need to figure something out, but the version resolver also needs to be replaced quite badly (which I’m working on).

0 Likes

#8

Thanks, good luck with the resolver. I’m kind of holding back for a few days on the issue with registering IIF v0.5.5 to see if more people are finding something similar, or if it’s just me.

Trying to add IIF in a fresh environment is still stuck with the assertion error p0 != p1 (linked above). Please let me know if you have any ideas on where I should look to fix?

0 Likes

#9

The problem with that release is that it has no compatibility bounds at all, which triggered the assertion error. If you add e.g.

[compat]
julia = "0.7, 1.0"

and re-release it should work. The previous registry didn’t allow packages to have 0 compatibility bounds.

1 Like

#10

Hi @fredrikekre, thanks – Registrator is not happy about overriding IIF v0.5.5, should I tag a new v0.5.6 instead or try fix v0.5.5?

PS, link to relevant documentation for compat is here:
https://docs.julialang.org/en/v1.0/stdlib/Pkg/#Compatibility-1

0 Likes

#11

Yea, thats what I meant. Releases are immutable.

0 Likes