Trouble installing an Excel reader

I’d like to read in some data from an Excel file, but I am having trouble installing an Excel reader. After issuing the using Pkg command, the following attempts all gave me the same error:
Pkg.add("XLSX")
Pkg.add("ExcelFiles")
Pkg.add("ExcelReaders")
Pkg.add("XLSXReader")
Pkg.add("Taro")

These all gave the following error:

ERROR: The following package names could not be resolved:

  • XLSX (not found in project, manifest or registry)

How can I install one of these? (I just need one of them to work! But ideally I’d like whatever is the recommended one.)

I don’t think this is an issue with Excel readers, as at a minimum two of these are in the General registry, so it looks like your registry is missing or corrupted? What are you getting from

(@v1.7) pkg> registry st
Registry Status 
 [23338594] General (https://github.com/JuliaRegistries/General.git)

(i.e. entering package REPL mode via ] and then running registry st)

1 Like

Maybe issuing a ] update ??

Hi, thanks for your reply. This is what I got:

Registry Status 
 [bbcd6645] JuliaComputingRegistry (https://github.com/JuliaComputing/JuliaComputingRegistry)```

Thanks for the reply. I tried that but strangely I got this message:

   Updating registry at `C:\Users\Michael\.julia\registries\JuliaComputingRegistry`
ERROR: expected package `Juno [e5e0dc1b]` to be registered```

Are you using JuliaPro? Maybe these packages aren’t in the JuliaPro registry, which I think is different from the General registry. Try adding the general registry as described here

1 Like

Ok I attempted to add the registry but it gave me this:

(@v1.5) pkg> registry add https://github.com/JuliaRegistries/General
    Cloning registry from "https://github.com/JuliaRegistries/General"
ERROR: SystemError: opening file "C:\\Users\\Michael\\.julia\\registries\\General\\Registry.toml": No such file or directory

(Though it seemed like it downloaded something before it gave me the error…not sure though…) And I don’t have JuliaPro installed, just Julia 1.5.3. Do I need to install JuliaPro? (Sorry if these are very dumb questions. I’m a complete Julia newbie.)

Try deleting C:\Users\Michael\.julia\registries\General and do a Pkg.update().

No you don’t need JuliaPro, but I was surprised to see that you got this JuliaComputing registry rather than just General

Just did that and here’s what I got:

   Updating registry at `C:\Users\Michael\.julia\registries\JuliaComputingRegistry`
ERROR: expected package `Juno [e5e0dc1b]` to be registered

I’m confused because I’m using VSCode, not Juno.

Why do you have the Juno package if you’re using VSCode? Are you getting the same error in a standard REPL outside of VSCode? If you’ve only just started and don’t have any environments etc. you want to preserve you can try deleting the whole .julia folder and start from scratch.

I actually downloaded Juno/Atom and Julia several months ago but only played with it for a couple hours. (I recently read a post somewhere that said VSCode was now preferred over Juno because Juno is no longer supported or something.)

I’m not sure what you mean by “standard REPL.” I’ll try your suggestion of removing Julia and starting from scratch. And this time I’m thinking I should download JuliaPro, because it seems to come with a lot of useful stuff I might want…Maybe that would fix the original issue?

So I uninstalled Julia and then downloaded and installed Julia Pro. I then tried to add the XLSX package in VSCode and in Atom, as I tried before, but it still didn’t work for either :frowning:

Update! I solved the issue by deleting the registries folder within my .julia folder. Then in the REPL I went into package mode and entered update. It then re-downloaded all of the contents from the registries folder. Once the folder was re-downloaded, I was able to install XLSX using the commands: using Pkg followed by Pkg.add("XLSX"). Many thanks, nilshg for taking the time to help me!!

1 Like