`TagBot`: release for new version not automatically triggered

Hi there,

I recently moved various packages from my own GitHub account into a new organisation. Yesterday, I added a new release for one of them to General and as usual TagBot was triggered (see here). I can also see that a new tag has been automatically created here. Unfortunately, a new release for that tag has not been automatically created and I don’t know why.

Perhaps this has to do with some default setting for the new organisation? Any help would be much appreciated!


1 Like

Do you have Julia TagBot · Actions · GitHub Marketplace · GitHub in the new organization as well?


Thanks @abelsiqueira, I have TagBot set up for each package repository. For the organisation, would I need to additionally configure a YAML here?

Edit: Or do I need to reset the deploy keys for each repo?

1 Like

According to this line (TagBot trigger issue · JuliaTrustworthyAI/CounterfactualExplanations.jl@d5b9d56 · GitHub) it looks like a permission failure. Can you check you https://github.com/JuliaTrustworthyAI/CounterfactualExplanations.jl/settings/actions in “Workflow permissions” if “Read and write permissions” is enabled?


Thanks a lot! It was read-only and enabling write access seems to have done something: the workflow now seems to run without issues: TagBot trigger issue · JuliaTrustworthyAI/CounterfactualExplanations.jl@d5b9d56 · GitHub

There’s still no new release for the tag, but I guess this may be due to the workflow being interrupted initially?

1 Like

I would trigger it manually, just to be sure. But it could also be this lookback period (Julia TagBot · Actions · GitHub Marketplace · GitHub). They have a more up-to-date TagBot.yml, it looks like it even handles the permission issues directly. Haven’t tried it yet, though.


All working now, thanks very much! (just pushed a new release for another package)

Another related issue, thought I’d ping you here @abelsiqueira :smiley: thanks again for you help!