TagBot does not create a GitHub release from a tag

I’ve registered a new release which has been merged into the General Registry, but the Julia TagBot doesn’t seem to be able to make a GitHub release. On the first try, it claimed there is a permissions-related error, but I’m using the same DOCUMENTER_KEY that I use to publish my documentation, which works correctly. TagBot does successfully get triggered and creates a tag with the changes from the last version.

When troubleshooting, I deleted the tag and ran TagBot manually. On the first run, I get the permissions error along with the new tag. When I run TagBot a second time, it says that since the tag already exists, there is no new version to release.

I can’t seem to pin down what the problem is or how to change my configuration. My TagBot.yml file follows exactly the same format as the recommendation and I have checked my permissions on GitHub for this repo.

Error after the first run:

GitHub returned a 403 permissions-related error.
                    Please check that your ssh key and TagBot permissions are up to date
Issue reporting failed

Result after the second run in Run JuliaRegistries/TagBot@v1:

Tag v1.1.0 already exists
No new versions to release

Does the branch name match? I ran into similar problems before realizing that i now use main but tagbot was looking for master

Yes, they match. And when I run it manually, I set it to the main branch. All of my other actions are set to look at main.