Symbol for \circ does not appear in the prompt

Hi, I tried to use \circ for the composition of functions. The composition works, but the symble º does not appear in the prompt. It shows instead a ?. I have added a screen shot below. How can I fix this behavior?


I am using julia version 1.6.0 under Windows.

Don’t use the Windows console — download the Windows Terminal to get better Unicode support. (On top of that, it wouldn’t hurt to get a better font.)


I use the Windows command prompt, but I told it to use a better font. I see \circ just fine.


Thank you. I have downloaded Windows Terminal. But, when I run julia from the prompt of Windows Terminal, the same repl format appears. How do I instruct julia to use the Windows Terminal?

Thank you. I will first try to fix the problem using windows terminal. How do I run julia through windows terminal and set it as default?

Just open the Windows terminal and type julia, if it’s 1.6 it should have been added to your PATH during installation.

If it’s not on your path either add it or cd to the Julia folder in the terminal and start it from there.

1 Like

Yes, it works. Thanks. It was not in path, though, although it is julia 1.6. I had to cd to the bin folder and type .\julia. Using start julia doesn’t work.

Do you know how can I set julia to run it through the Windows Terminal (PowerShell) as default? That is, when I click julia from the start menu, to make it use the Windows Terminal?

you can define Powershell aliases (see my response here), so that julia will launch your prefered version of Julia