Studio closes pane with each plot command

After latest update VS code now closes the plotting pane and shifts focus to plot tab after each plot.
My first question is how do I stop this.
My second question is how do I disable these updates and pre-compilations each time I restart VS code.
They have been a source of unpredictability and instability in general.
Thank you.

I guess it is this issue Plots appear in new tab in same editor group as the generating code instead of in a new editor group · Issue #2618 · julia-vscode/julia-vscode · GitHub, isn‘t it?

1 Like

Had the same behavior.

My solution:
In the menu of the code pane(“more actions” - the 3 dots in the upper, right corner) , I selected “lock group” and the plot-pane was “normal” again on my PC.

2 Likes

You are correct, and it’s similar times.
Sounds like a real hassle and it seems to me the issue here is that VScode updates automatically with each launch of the program.
Seems like it would be a good idea to disable this feature except for versions that were verified to not break the Julia environment.

Well done!
I tried this before with the plots pane but it didn’t solve the problem.