VS code plot pane won't stay splitted

Recently (past week or so), I noticed a change of behavior in how VS Code Julia plot pane displayed figures.

Before it looked like that every time I plotted a new figure

But now when I Shift+Enter inline plot, it produces that


Meaning the right panel opens in full screen over the left panel.

If I try from the REPL, it sometimes (not always and that is weird) keep the split format and sometime display the plot pane in all the screen.

Here are my settings, I use VS Code insider.

VS Code Julia extansion v1.5.6
Julia Version 1.6.3
Commit ae8452a9e0 (2021-09-23 17:34 UTC)
Platform Info:
  OS: Windows (x86_64-w64-mingw32)
  CPU: Intel(R) Core(TM) i7-7600U CPU @ 2.80GHz
  WORD_SIZE: 64
  LIBM: libopenlibm
  LLVM: libLLVM-11.0.1 (ORCJIT, skylake)
Environment:
  JULIA_EDITOR = code-insiders

It might be related to that issue but I did not get how to change the setting to always display the plot in split window without opening the plot in full screen.

6 Likes

Did you try dragging the plot pane into a new editor group manually? IIRC we’ll remember the last column the plot pane was opened in and always try to use that.

Yes I tried that, but at each new plot, it re-opens again as full screen, suppressing the split.
Here is what happen (I just using Plot and do a first plot to avoid compilation time).
2021-11-25 16-45-55

Sorry if we don’t see much, I am not expert in screen recording.

3 Likes

I noticed this too as of today, having just upgraded to VSCode 1.63.0 yesterday - potentially related?

2 Likes

I’ve opened an issue here: Plot pane not staying in vsplit · Issue #2612 · julia-vscode/julia-vscode · GitHub

3 Likes

Will be fixed by Fix plot pane column and focus issues by pfitzseb · Pull Request #2611 · julia-vscode/julia-vscode · GitHub.

9 Likes

Ah nice! I had a look through the issues but couldn’t find an existing one - evidently I didn’t look hard enough :slight_smile:

Hi there.

This is not fixed for my settings I’m afraid.

Julia VScode extension: v1.5.8
VSCode Version: 1.63.2
Electron: 13.5.2
Chromium: 91.0.4472.164
Node.js: 14.16.0
OS: Darwin x64 19.6.0’

Here is an issue following the problem: Plots appear in new tab in same editor group as the generating code instead of in a new editor group · Issue #2618 · julia-vscode/julia-vscode · GitHub

For the moment I had to downgrade VSCode 1.62

1 Like

Oh I notice it too, but I actually prefer this behaviour because I’m on a laptop with little screen real estate :face_with_hand_over_mouth:

P.S. my plots are much wider than yours though, which is why I like the behaviour. Maybe a different default size? I wouldn’t like it so much if my plots were as small as yours!

same problem here. looked through the web and no solutions.

waiting for bug fixes.

2 Likes

This didn’t work for me, unfortunately. Plot pane keeps jumping back over to the left pane each time I run my function that contains lines(), using CairoMakie.jl.

I first deleted all plots so that the plot pane shows “Julia Plots (0/0)” and dragged to the right manually, then I chose “Lock Group” as @zdenek_hurak said and it worked!

1 Like

I tried it, unfortunately still pops over to the left each time I run the function in the REPL that creates it. I also restarted VS Code, opened the plot plot before plotting anything and locked it. Still moves over to the left.

I’m experiencing the same isse with CarioMakie.jl

Unfortunately, the issue appears again randomly. At the moment, either we have to downgrade to Version 1.62 as @lmiq suggested or bear with the current behavior and wait for the next fix.