Plot Pane Issue

I’m not sure what I’ve done, but in VSCode my plots no longer show up in the plot pane when I do shift+enter. I am using VSCode Version 1.81.1 and Julia extension v1.49.2.

For example until yesterday I could do the following.

    f = Figure()
    ax = Axis(f[1, 1],
        title="A Makie Axis",
        xlabel="The x label",
        ylabel="The y label"
end # shift+enter, executes this entire block and the plot pane shows up (plot pane counter goes to 1/1)
f # shift+enter again, plots again (counter goes to 2/2)

Now when I do this it only outputs Figure() in-line.
I made sure I have the following setting enabled "julia.usePlotPane": true. I also checked and VSCodeServer.PLOT_PANE_ENABLED[] returns true in the connected REPL.

Note that I can get the plot to show up if I go down to the REPL and enter f. But it is much easier to shift+enter when I am interactively studying simulation results.

Any advice on how to resolve this would be appreciated.

I tried to replicate this issue but failed, except that there is an option in the settings for the Julia Plugin called julia.execution.codeInREPL which was set to false for me. Setting it to true or checking the mark does echo the executed code in the REPL again, as it was expected by me.

There seem to be more options available for code execution, you may check them too. julia.execution.resultType seems to be related too.

I do not use this feature a lot, so I don’t know if anything changed or if it is something else in your case.

The plot pane opens and counts up with every shft/enter on my system. (using CairoMakie)

Also try again with the newest version of the extension, which, IIRC fixes an edge case related to plots not being shown in some code execution variations.

My plot pane has also gone after updating to Julia extension v1.49.2 just now. Tried the pre-release version and that too did not show plots. Using Julia 1.9.2 on Windows. Use plot pane is set to true in the extension settings.

Issue persists in the pre-release v1.51.1.

I tried setting that to true. Did not fix the issue for me even though I can see the code echoed in the integrated REPL. I have to manually enter the code into the REPL and then hit enter for the plot pane to show up or update.

Issue is fixed for me in v1.51.2 of the Julia extension.

1 Like