Strange behaviour of VS Code


#1

Hi all,

Following observation made based on VS code (1.30.2) using Julia 1.03

The code line below behaves differently depending on how I run the code.

xval = range(0,stop=50,length=1000)

If I run the line with CTRL+Enter all is fine. However, running the line pressing the ‘Play’ button or (CTRL+ALT+N), respectively, the following error occurs:

LoadError: function range does not accept keyword arguments

Any ideas ? Of course the given code snippet is from a longer code which due to that cannot be run with a single mouse click.

Thanks in advance


#2

We don’t hook into the play button yet, so it is probably trying to do something entirely different that is unrelated to julia. It is on my (too long) list of todos to properly hook into the run experience in VS Code. No promise when that will happen, though.


#3

Ah ok, thank you for the information. Thought, this issue was somehow related to coderunner. So I wonder how others run longer code in VS Code. Line by line ?

Regards

ceysa


#4

I think F5 should work, if you have a file open. Ideally save it before you run it.