Strange error in VS code input

error

#1

Hello.

I’ve been using Julia on VS code with language-julia-0.11.0-beta.2.vsix for several days but today it doesn’t work. I don’t know why.

Whatever I try to run on the main editor it adds it a prefix “200~” and generates an error.

For example:
using DataFrames, GLM

produces:

200~using DataFrames, GLM
ERROR: MethodError: no method matching ~(::Int64, ::Int64)
Closest candidates are:
  ~(::Union{Int128, Int16, Int32, Int64, Int8, UInt128, UInt16, UInt32, UInt64, UInt8}) at int.jl:274
  ~(::Integer) at int.jl:138
Stacktrace:
 [1] top-level scope at none:0

Has anyone had the same problem?
Do you think is a problem wit VS Code, the extension or with Julia?
running the code directly on the REPL works well.
I’ve tried reinstalling the extension but the problem is still there.


#2

Could you open an issue with this over at https://github.com/JuliaEditorSupport/julia-vscode? Thanks!


#3

I’ve done it.

I’ve also tried reinstalling a different version of VS Code but the problem persists.

PD: I’ve reinstalled the the extension beta1 and it works but beta2 doesn’t.


#4

Select all the code and then press Ctrl-Enter for the Beta2 version to execute the code. For some reason this version does not work with the F5 key to execute the file. It worked OK on the previous version.


#5

I wasn’t using the F5 key but Ctrl+Enter.


#6

Thanks.
I had the exact same issue.
Thank you for mentioning that beta 1 works (this is the case for me as well)!
I also note that, in order to installe the beta release, ‘double clicking’ the vsix did not work for me; instead I had to browse for the file in the extensions menu in VS code.