Start REPL: The terminal process failed to launch: Path to shell executable "\bin\sh" does not exist

since today I cannot launch a REPL from VSCode on windows anymore. It fails with the error:
The terminal process failed to launch: Path to shell executable "\bin\sh" does not exist.
I interpret this as the julia extension not being able to launch a terminal, although I am not sure what exactly goes wrong since the command “Terminal: Create new terminal” works fine. Possibly there is some setting that now automatically assumes that the user is on a linux OS? ( the path “\bin\sh” seems to indicate this)

I think the problem started after a vscode update. I initially updated Julia using UpdateJulia.update_julia("1.9"). After restarting vscode to acccess the new version, it automatically installed an update that seemed to have broken things.

I have found a number of results upon looking up this error, but so far nothing that seemed to be out of place for me. Most results are referring to providing a path for the terminal executable, but that seems to be specified correctly for me.

Some more pointers:

  • When I use remote-ssh into another machine (linux) and start a REPL from there, it works fine.
  • Starting a julia session manually in a normal terminal and connecting to the REPL works as usual.
  • I have tried reinstalling the extension to no avail.

Has anyone had this problem before?

I have figured out the problem. There was a setting about persistent settings which I had overlooked. Looks like vscode synced my setting from another computer and tried to find the shell in /bin/sh.
Disabling persistent sessions or selecting a different shell seems to solve the problem