[solved] Julia throws "PowerShell version < 3" error, when PowerShell is >3

question

#1

This just happened, so some update has broken something. I saw this originally last year, but I can’t recall how I fixed it. Why would Julia/Atom get confused on what version of PowerShell I am running?

I’m on a Windows 7 Professional corporate machine, everything should be up to date.

Pete


#2

What exactly causes the error (i.e. example triggering the error)? Is it from Atom or Julia.


#3

I’ve seen this pop up sporadically, but never consistently unless it’s actually correct.
Can you give me the ouput of powershell $PSVersionTable.PSVersion evaluated in the command line?


#4

It triggers every time I start up Atom. It doesn’t if I start the command line version of Julia.

PS C:\Windows\System32\WindowsPowerShell\v1.0> 
$PSVersionTable.PSVersion

Major  Minor  Build  Revision
-----  -----  -----  --------
4      0      -1     -1

I noticed that the powershell dropped out of my path (yay corporate IT meddling again!) so I suspect that is part of the problem. Fixing that situation now.

…typing typing typing…

…and it’s fixed. I was launching powershell from a desktop icon which had the path hardwired. Launching it from the command line is the real test.