Error with new versions


#1

I’m a Julia rookie trying to update to the newer versions of Julia on a Windows machine. I successfully installed V0.5, but could never get V0.5.1, V0.5.2, and now V0.6 to install. When I run the installation file after downloading, it says it’s installed everything. But running the julia.exe to start the REPL just flashes the REPL on the screen then immediately goes away. Uninstalling and reinstalling does the same thing. Any help would be great; I’d love to not be stuck in the 0.5 world while everyone else is moving forward.

Thanks in advance.


#2

Please try running julia.exe in the console (cmd.exe) and post any errors. Perhaps also include whether it is on a shared network drive, and if you have a local firewall running.


#3

No errors when I run from the console. It seems to install just fine. Running julia.exe from the V0.6.0 folder from console says:
"ERROR: System image file failed consistency check: maybe opened the wrong version?"
Is that an error with how the julia command is set up in the console? I don’t see how that would effect trying to run the 0.6.0 version.


#4

Well I’ll be. I had an environment variable set for 0.5.0, and changing it to 0.6.0 seems to have fixed it. Thanks for the help ihnorton!


#5

@jayreif for the benefit of future search users, what was the environment variable in question?


#6

On Windows, it’s usually something like JULIA_HOME. Don’t know for other implementations.


#7

$JULIA_HOME which I believe I had I to set up be able to call Julia from the command line or powershell, but I can’t find the guide that took me to doing that anymore. Anyway, $JULIA_HOME was set to the binary fines of Julia-0.5.0, and all I did to fix it was change it to Julia-0.6.0. I imagine I’ll need to do the same for future updates.


#8

Ah, yeah, that seems like it would be a problem.

I haven’t used Julia on Windows much, but I’d be surprised if setting JULIA_HOME was actually necessary. If you don’t mind experimenting, what happens if you just remove that environment variable entirely? If it is necessary in some cases, then we should fix the docs.


#9

Setting $JULIA_HOME and adding %JULIA_HOME% to your system or user path is definitely necessary to run Julia from PowerShell. Of course, you can always code the full executable path in your path variable instead! Using JULIA_HOME is much cleaner and easier to maintain.


#10

You should never need to set JULIA_HOME unless you’re doing something custom with embedding. People setting JULIA_HOME because they wanted to for their own reasons (or mistakenly thought they needed to?) and it causing immediate errors on startup is a very commonly reported problem.


#11

And it’s almost always a bad idea to add Julia’s bin folder permanently to your system path on windows (adding it temporarily only for the lifetime of the julia process is better). Julia’s bin folder has many dependency dll’s like openblas, llvm, libgmp, mpfr, libgit2, etc. Any other program in the world that happens to depend on those same libraries may require slightly different versions or build configurations of them than Julia requires, so adding Julia’s bin folder to your system path could easily break those unrelated programs.

A much safer way of allowing you to use just julia to launch a REPL from a powershell prompt would be setting a shell alias in your profile (https://mcpmag.com/articles/2014/06/10/exe-alias-in-powershell.aspx). This works nicely on unix too, though since shared libraries and executables are in different folders there’s less of a pollution problem to worry about.


#12

Thank you for the clarification. Not having a fixed setting makes it much easier to run multiple versions. I will definitely change my setup.