Problem when using Pluto (UnauthorizedAccess on Windows)

Hi everyone

I am a bit clueless about the following: I recently updated to Julia 1.10.0 which I installed via the Microsoft store. Everything seemed fine so far. Now, I wanted to use a Pluto.jl notebook. When starting up, I received the following notification:

[ Info: Loading...
. : File C:\Users\[my user name]\Documents\WindowsPowerShell\profile.ps1 cannot be loaded because running scripts is disabled
on this system. For more information, see about_Execution_Policies at https:/
At line:1 char:3
+ . 'C:\Users\[my user name]\Documents\WindowsPowerShell\profile.ps1'
+   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : SecurityError: (:) [], PSSecurityException
    + FullyQualifiedErrorId : UnauthorizedAccess
┌ Info:
└ Opening http://localhost:1234/?secret=h5HBwzCa in your default browser... ~ have fun!
┌ Info:
│ Press Ctrl+C in this terminal to stop Pluto

Afterwards, Pluto opened like usual in my browser but when I tried to save a notebook in a specific folder I got notified that

Failed to move file:

Pluto update_notebook error: (from Julia: SystemError: opening file "C:\\Users\\[my user name]\\Documents\\Codes": Permission denied)

I understand that this has to do with my PowerShell settings. However, for my previous version of Julia (1.8.5) I never had any related problems with running Pluto on the same machine with the same settings.
Does anyone know whether this is related to installing Julia via the Windows store? (which I didn’t use for downloading Julia 1.8.5).
And will I need to change the settings?

I’m not sure if this is the issue or not, but I would personally recommend installing Julia using the official juliaup tool or by downloading an exe directly from the site. Quite a lot of unusual issues like this that get posted about ultimately turn out to be related to installations from unofficial or simply less well maintained sources.

For Windows, the Microsoft store is one of the recommended installation sources for Julia/juliaup: GitHub - JuliaLang/juliaup: Julia installer and version multiplexer

1 Like

Exactly. Previously I just downloaded the exe, due to the recommendation on the Julia download page recommendation I used the windows store this time.

As an update: In the end, I managed to sort the thing out by renaming the powershell profile profile1.ps1, which was put there by Python Anaconda, essentially following the solution for this discourse thread.

I am still a bit wondering what was going on though, I had an anaconda installation way before the problem described above appeared.

1 Like

I clicked through wondering who could have possibly figured that out only to find past me. Trippy. I’m glad it solved your problem.