Problem to use julia v0.7 in VS Code

I have installed julia v0.7 plug-in in VS Code but I got the following error when I tried to use it:

Could not start the julia language server. Make sure the configuration setting julia.executablePath points to the julia binary.

I have read this discussion :
https://github.com/julia-vscode/julia-vscode/issues/537
but it was not too helpful.
Anyone could help me with this issue?
The steps I have used were:

  1. install VS CODE : https://code.visualstudio.com/
  2. install Julia for VS CODE:https://marketplace.visualstudio.com/items?itemName=julialang.language-julia

After this steps, I got Julia installed into VS Code but it is just not working …


Thanks for the help!

Why 0.7? If you can, better switch to 1.0 (or higher)…

1 Like

0.7 is useful if you’re trying to migrate code from 0.6 to 1.x since it’s got all the deprecations and suggestions for how to fix. Otherwise, definitely upgrade.

1 Like

Versions pre 1.0 are not supported, I’m afraid. I don’t see that changing, keeping the support for Julia 1.0.x around is painful enough and we simply don’t have the person-power to support even older versions.

1 Like

Thanks for this clarification. I cannot immediately migrate to 1.0 because I need to review my whole project because it was coded in 0.6 version, so deprecated messages are useful to help me in this task. I was normally using v 0.7 in ATOM but suddenly it has stopped to work, so I have tried to switch to VS Code. I have tried the most of the advice to make julia v0.7 works in ATOM again but nothing seems to work. In this case, i really don’t know how to do…

Just use 0.7 from the REPL to get the deprecation messages and then edit your 1.0 codebase in Juno?

I have a huge code so it’s not practical to use REPL…I need follow the construction of the model step by step to make sure everything is ok before sending my equations to the solver…(i have been using JuMP).