Julia Pro Installation Error [Ubuntu]


I am trying to install JuliaPro 1.4.1 in Ubuntu but am getting an error once I run the commands in Ubuntu terminal. I have followed both the instruction manual and also the discussion on another installation question topic.

I have made sure that the folder exists and that the name of the folder is correct too but following is the error that I have been receiving:

sudo ./JuliaPro-1.4.1-1_build-94.sh home/waqas/Julia 1.4.1

Do you want to configure your JuliaPro to work with your private JuliaTeam package server? [Yes/No(default)]
JuliaPro installation has started, please wait until all the files are extracted

Installing JuliaPro-1.4.1-1 to pkg.juliacomputing.com
JuliaPro will be configured to use following package server: 
Running postinstall script, this might take a while
chmod: cannot access 'pkg.juliacomputing.com/JuliaPro-1.4.1-1/Launch_JuliaPro': No such file or directory
JuliaPro installation completed

Following are the lines of code that I used to install prerequisites and change permission of .sh file.

sudo apt-get -y install xclip
sudo apt-get -y install libgconf-2-4

chmod 777 JuliaPro-1.4.1-1_build-94.sh
./JuliaPro-1.4.1-1_build-94.sh home/waqas/Julia 1.4.1

I am new to ubuntu and have been trying to learn Julia for quite a while now. But every time I tried to install Mongoc.db I was getting errors in windows10 so the only reason I have installed Ubuntu was to see if the problem is resolved or not.

Looking forward to your suggestions

It looks like the installation succeeded. What is the actual error you are seeing? What are you failing to achieve? Some more explanation would be useful.

The installation path home/waqas/Julia 1.4.1 might be invalid, can you try with an absolute path?

What do you mean by full path? To my understanding, I am giving complete path already. Sorry, I am fairly new to Ubuntu so pardon my ignorance.

My understanding is that this error is coming from .sh file.

No, I got the following error:

When I also double-checked the folder but that is empty too. However, in pkg.juliacomputing.com folder, generated by chmod, I can see that Launch_JuliaPro file exists.

Can you try following command and let us know if this fixes the installation issue?

./JuliaPro-1.4.1-1_build-94.sh /home/waqas

Above command would create following folder: /home/waqas/JuliaPro-1.4.1-1 and install JuliaPro into that path

It returned the same error. As I mentioned above, I was able to open pkg.juliacomputing.com and was able to locate the file that is mentioned as “no such file or directory”.

Can the problem be related to something like this thread where the actual file exists but the loader is not able to load it?