Plots are tiny

Within the last two months, my plots started rendering as tiny in VS Code.

If I set the default size as (900,600), my plots are tiny:
image

if I change it to (3600,2400), my plots get bigger:

VS Code correctly detects my screen resolution (1920,1080), but for some reason rendering (streaming?) this over ssh (CentOS7 with ENV_GKS_WS = 100) results in a way scaled down image. When I write the plot to disk as a PNG, it loads at the expected size.

VS Code Julia extension 1.0.10
VS Code 1.52.1
Julia 1.5.3

As a workaround the option fmt=:png might work. It worked for me when using Pluto.jl.

plot(rand(10),fmt=:png)

Thanks for the suggestion, but this did not affect it.

Plots in the plot window are usually smaller. I believe there’s an icon that appears on hover which you can use to open the plot previews in a separate tab. That tab should allow for zooming in and usually renders at a higher resolution.

I go through SSH (to a Julia dev environment container via the remote - containers addon), so it pops up in a separate tab all the time with no hover-over properties and used to default to full resolution.

It is interesting that the default behavior is thumbnail and probably hints to the cause of my problem.

That default behaviour only applies to the built-in plot pane IIRC. I’m not sure what’s going on if you have a separate window popping up.

Sorry for being unclear. This is in the VS Code interface (not a separate window, just a separate tab) and it looks like this:
image

Yup, that was what I was referring to (s/window/tab). Looks like either the hover functionality was removed or I was confusing it with the Python plots window. Either way, your best bet is probably to file an issue.

1 Like

Alright then, ticket made. Thanks for the assistance with my strange problem!

For the record: this post lead to this GR plot issue. Updating GR to v0.53.0 fixed it for me. Thanks for the directions!

(@v1.5) pkg> add GR@0.53.0