Package not opening PR for updating

Hi,

I’m working in a new package and tried the first update. However even after an hour nothing happened when I called the [@JuliaRegistrator register().

The package registered fine so I don’t know what is happening here.

Another strange thing with this package is that the documenter only creates Previews of the docs, but no dev or similar. See GitHub - GenericMappingTools/RemoteS.jl at gh-pages

Any idea on what is going on here?

For Documenter, the devbranch keyword argument defaults to master, so that could be why your push to main is considered to be a preview.

EDIT: See deploydocs for more info: Public · Documenter.jl

EDIT2: And remove the parenthesis from the @JuliaRegistrator register() to make that work

1 Like

Thanks for looking into this. Up into the detail of noticing that I’m pushing to main instead of master. Nothing that I can do. GitHuib decided that master can be an offensive word and now all new repos are mains and not masters

Regarding the parenthesis, I don’t see why it would be an error. I’ve updated a package dozens of times with register() and that was never a problem. Last time was yesterday

Ok, I tried to set the devbranch to main in make.jl but had to comment the line

versions = ["stable" => "v^", "v#.#", devurl => devurl],

as exemplified in Public · Documenter.jl because it kept erroring

unfortunately no difference. Still only previews … an no updates.

EDIT: Update the dev directory showed up after a while. Uff.

Found the registrator issue. I forgot that I have to install it on every new package. Sought the one in organization would be usable by new projects, but no. My Bad. Sorry.