"New Terminal" does not work

I clicked on Atom tool bar New Terminal button and this error message came up:

For more info check out the docs: https://nuclide.io/docs/features/terminal

Error starting process:

Error: Cannot find module 'C:\Users\zpan\.atom\packages\atom-ide-ui\node_modules\nuclide-prebuilt-libs\pty\build\pty-node-v64-win32-x64\pty.node'

Tried closing Atom and uninstalling and installing atom-ide-ui using “apm”. No use.

I Googled pty-node-v64-win32-x64 and found this release page: https://github.com/facebook-atom/nuclide-prebuilt-libs/releases

I downloaded this file from the page: pty-node-v64-win32-x64.tar.gz

Closed Atom. Extracted files into the folder “pty-node-v64-win32-x64” and copy-pasted the folder into: C:\Users\zpan.atom\packages\atom-ide-ui\node_modules\nuclide-prebuilt-libs\pty\build\

Restarted Atom.

Tried New Terminal again and now this error message showed up instead:

For more info check out the docs: https://nuclide.io/docs/features/terminal

Error starting process:

Error: A dynamic link library (DLL) initialization routine failed.

\\?\C:\Users\zpan\.atom\packages\atom-ide-ui\node_modules\nuclide-prebuilt-libs\pty\build\pty-node-v64-win32-x64\pty.node

Searched the error message online and found this page:

It seems I need to rebuild the native Node addon for Electron, the steps are outlined in the docs. However, the steps assume I have “npm” which I don’t.

Can someone help how to proceed from here?

The atom-ide-ui version is 0.13.0. Below is the Juno Debug Info:

# Atom:

Version: 1.40.0

Dev Mode: false

Official Release: true

{

  "http_parser": "2.8.0",

  "node": "10.2.0",

  "v8": "6.6.346.32",

  "uv": "1.20.3",

  "zlib": "1.2.11",

  "ares": "1.14.0",

  "modules": "64",

  "nghttp2": "1.29.0",

  "napi": "3",

  "openssl": "1.1.0h",

  "electron": "3.1.10",

  "chrome": "66.0.3359.181"

}

# julia-client:

Version: 0.9.4

Config:

{

  "firstBoot": false,

  "uiOptions": {

    "enableMenu": true,

    "enableToolBar": true,

    "errorNotifications": false,

    "layouts": {

      "console": {

        "defaultLocation": "right"

      },

      "defaultPanes": {

        "plotPane": false

      },

      "documentation": {

        "defaultLocation": "right",

        "split": "no split"

      },

      "linter": {

        "defaultLocation": "right"

      },

      "plotPane": {

        "defaultLocation": "right",

        "split": "no split"

      },

      "profiler": {

        "defaultLocation": "right",

        "split": "no split"

      },

      "terminal": {

        "defaultLocation": "right"

      },

      "workspace": {

        "defaultLocation": "right",

        "split": "no split"

      }

    },

    "usePlotPane": false

  }

}

# ink:

Version: 0.10.12

Config:

undefined

# uber-juno:

Version: 0.2.0

Config:

{

  "disable": true

}

# language-julia:

Version: 0.19.1

Config:

undefined

# language-weave:not installed

# indent-detective:

Version: 0.4.0

Config:

undefined

Julia Version 1.1.1

Commit 55e36cc308 (2019-05-16 04:10 UTC)

Platform Info:

  OS: Windows (x86_64-w64-mingw32)

  CPU: Intel(R) Core(TM) i7-6600U CPU @ 2.60GHz

  WORD_SIZE: 64

  LIBM: libopenlibm

  LLVM: libLLVM-6.0.1 (ORCJIT, skylake)

Environment:

  JULIA_EDITOR = "C:\Users\zpan\AppData\Local\atom\app-1.40.0\atom.exe"  -a

  JULIA_NUM_THREADS = 2

    Status `C:\Users\zpan\.julia\environments\v1.1\Project.toml`

  [537997a7] AbstractPlotting v0.9.8

  [b19378d9] ArrayFire v1.0.1

  [c52e3926] Atom v0.9.0

  [6e4b80f9] BenchmarkTools v0.4.2

  [336ed68f] CSV v0.5.9

  [c5f51814] CUDAdrv v3.1.0

  [be33ccc6] CUDAnative v2.2.1

  [49dc2e85] Calculus v0.5.0

  [aaaa29a8] Clustering v0.13.2

  [da1fd8a2] CodeTracking v0.5.7

  [3a865a2d] CuArrays v1.1.0

  [a93c6f00] DataFrames v0.19.1

  [864edb3b] DataStructures v0.17.0

  [31a5f54b] Debugger v0.5.0

  [7806a523] DecisionTree v0.8.3

  [0c46a032] DifferentialEquations v6.6.0

  [31c24e10] Distributions v0.21.1

  [ffa9a821] DocumentFormat v0.4.1

  [7a1cc6ca] FFTW v0.3.0

  [59287772] Formatting v0.3.5

  [38e38edf] GLM v1.1.1

  [e9467ef8] GLMakie v0.0.6

  [28b8d3ca] GR v0.41.0

  [c91e804a] Gadfly v1.0.1

  [f67ccb44] HDF5 v0.12.0

  [09f84164] HypothesisTests v0.8.0

  [6a3955dd] ImageFiltering v0.6.4

  [6deec6e2] IndexedTables v0.12.2

  [d0351b0e] InspectDR v0.3.6

  [c601a237] Interact v0.10.2

  [a98d9a8b] Interpolations v0.12.2

  [6042db11] JDBC v0.4.1

  [4138dd39] JLD v0.9.1

  [682c06a0] JSON v0.21.0

  [494afd89] JavaCall v0.7.1

  [a93385a2] JuliaDB v0.12.0

  [aa1ae85d] JuliaInterpreter v0.6.1

  [e5e0dc1b] Juno v0.7.1

  [1902f260] Knet v1.2.3

  [b964fa9f] LaTeXStrings v1.0.3

  [fc18253b] LazyJSON v0.1.1

  [093fc24a] LightGraphs v1.2.0

  [9c8b4983] LightXML v0.8.0

  [6f1432cf] LoweredCodeUtils v0.3.6

  [10e44e05] MATLAB v0.7.3

  [ee78f7c6] Makie v0.9.4

  [e7bfaba1] NumericalIntegration v0.2.0

  [09606e27] ODEInterfaceDiffEq v3.3.1

  [47be7bcc] ORCA v0.2.1

  [429524aa] Optim v0.19.2

  [3b7a836e] PGFPlots v3.1.3

  [9b87118b] PackageCompiler v0.6.4

  [d96e819e] Parameters v0.10.3

  [58dd65bb] Plotly v0.2.0

  [f0f68f2c] PlotlyJS v0.12.5

  [91a5bcdd] Plots v0.26.0

  [f27b6e38] Polynomials v0.5.2

  [438e738f] PyCall v1.91.2

  [d330b81b] PyPlot v2.8.1

  [6f49c342] RCall v0.13.3

  [ee283ea6] Rebugger v0.3.2

  [295af30f] Revise v2.1.6

  [f2b01f46] Roots v0.8.1

  [276daf66] SpecialFunctions v0.7.2

  [2913bbd2] StatsBase v0.32.0

  [b8865327] UnicodePlots v1.1.0

  [fdbf4ff8] XLSX v0.5.4

  [a5390f91] ZipFile v0.8.3

atom-ide-ui is unmaintained (and completly separate from Juno). The update to Atom 1.39 broke all terminal libraries, and I think that Juno’s terminal is the only one that’s working (although there have been some bug reports coming in with the release of Atom 1.40…)

Thanks for the info! I’m on Atom 1.40. Guess I just need to wait for a fix then…

Meanwhile I’m using atom-terminal-powershell to get by since I’m on Windows. It’ll open a standalone new window when Ctrl-Shift-T is pressed, so it’s not ideal for the workflow. Works as a substitute while I wait for the fix… :slight_smile:

Following your info I found these online. Guess I shouldn’t be holding my breath for any fix in near future then…