ModelingToolkit takes forever to precompile on Windows 11

I use Windows 11 on an HP Dragonfly laptop. I’ve added a package, and precompiling/updating takes “forever”: I did this change yesterday evening, went out for a meal, etc., and this morning (12 h later or so), the laptop is still working on it:

My suspicion is that this is somehow related to the power management system on the laptop. But…

  • The laptop is plugged to the power grid (turn off screen & put to sleep: both “Never”)
  • Under Bluetooth & devices, there is an option under USB that says “Stop USB devices when my screen is off…”. Probably not necessary, but I disabled that one in case the OS thinks that it should turn off USB charging when the screen is off.
  • HP has their own set-up for “HP Auto Lock and Awake” with rather sparse information – I haven’t touched that one.

Anyways, anyone with similar experience?


Something seems wrong. It should not 12-hours.

Could you provide the output of the following?

using Pkg
Pkg.status(; mode=Pkg.PKGMODE_MANIFEST)

Also, do you have anti-virus software installed? This can interfere with the process. Also make sure you have plenty of disk space.

1 Like

Sorry for delay in response…

  1. Anti-virus software: only the default by Microsoft. Has never created problems before.
  2. Disk space: 1.16 TB free space on a 2TB disk. [32 GB RAM]

Output from Pkg statements…

using Pkg
julia> Pkg.status()
Status `C:\Users\XXX\.julia\environments\v1.10\Project.toml`
⌅ [c3fe647b] AbstractAlgebra v0.40.9
  [6e4b80f9] BenchmarkTools v1.5.0
  [764a87c0] BoundaryValueDiffEq v5.7.1
  [336ed68f] CSV v0.10.14
  [a6e380b2] ControlSystems v1.10.2
  [687d7614] ControlSystemsMTK v2.1.0
  [a93c6f00] DataFrames v1.6.1
⌅ [82cc6244] DataInterpolations v4.8.0
  [0c46a032] DifferentialEquations v7.13.0
⌅ [5b8099bc] DomainSets v0.6.7
  [0b43b601] Groebner v0.7.4
  [7073ff75] IJulia v1.24.2
  [b964fa9f] LaTeXStrings v1.3.1
  [23fbe1c1] Latexify v0.16.3
  [94925ecb] MethodOfLines v0.11.0
  [961ee093] ModelingToolkit v9.14.0
  [16a59e39] ModelingToolkitStandardLibrary v2.7.1
⌅ [2edaba10] Nemo v0.43.3
⌃ [8913a72c] NonlinearSolve v3.11.0
  [1dea7af3] OrdinaryDiffEq v6.78.0
  [91a5bcdd] Plots v1.40.4
  [f27b6e38] Polynomials v4.0.8
  [0c5d862f] Symbolics v5.28.0
Info Packages marked with ⌃ and ⌅ have new versions available. Those with ⌃ may be upgradable, but those with ⌅ are restricted by compatibility constraints from upgrading. To see why use `status --outdated`

I tried to install and compile Oscar.jl, but got error messages stating it only works on Linux. So I did Pkg.rm("Oscar").


julia> Pkg.status(; mode=Pkg.PKGMODE_MANIFEST)
Status `C:\Users\XXX\.julia\environments\v1.10\Manifest.toml`
⌅ [47edcb42] ADTypes v0.2.7
⌅ [c3fe647b] AbstractAlgebra v0.40.9
  [621f4979] AbstractFFTs v1.5.0
  [1520ce14] AbstractTrees v0.4.5
  [7d9f7c33] Accessors v0.1.36
  [79e6a3ab] Adapt v4.0.4
  [66dad0bd] AliasTables v1.1.3
  [ec485272] ArnoldiMethod v0.4.0
  [4fba245c] ArrayInterface v7.10.0
  [4c555306] ArrayLayouts v1.9.3
  [a9b6321e] Atomix v0.1.0
⌃ [13072b0f] AxisAlgorithms v1.0.1
  [aae01518] BandedMatrices v1.7.0
  [6e4b80f9] BenchmarkTools v1.5.0
  [e2ed5e7c] Bijections v0.1.6
  [d1d4a3ce] BitFlags v0.1.8
  [62783981] BitTwiddlingConvenienceFunctions v0.1.5
  [764a87c0] BoundaryValueDiffEq v5.7.1
  [fa961155] CEnum v0.5.0
  [2a0fbf3d] CPUSummary v0.2.5
  [00ebfdb7] CSTParser v3.4.3
  [336ed68f] CSV v0.10.14
  [49dc2e85] Calculus v0.5.1
  [d360d2e6] ChainRulesCore v1.23.0
  [fb6a15b2] CloseOpenIntervals v0.1.12
  [944b1d66] CodecZlib v0.7.4
  [35d6a980] ColorSchemes v3.25.0
  [3da002f7] ColorTypes v0.11.5
  [c3611d14] ColorVectorSpace v0.10.0
  [5ae59095] Colors v0.12.11
  [861a8166] Combinatorics v1.0.2
  [a80b9123] CommonMark v0.8.12
  [38540f10] CommonSolve v0.2.4
  [bbf7d656] CommonSubexpressions v0.3.0
  [34da2185] Compat v4.15.0
  [b0b7db55] ComponentArrays v0.15.13
  [b152e2b5] CompositeTypes v0.1.4
  [a33af91c] CompositionsBase v0.1.2
  [2569d6c7] ConcreteStructs v0.2.3
  [f0e56b4a] ConcurrentUtilities v2.4.1
  [8f4d0f93] Conda v1.10.0
  [187b0558] ConstructionBase v1.5.5
  [d38c429a] Contour v0.6.3
  [a6e380b2] ControlSystems v1.10.2
  [aaaaaaaa] ControlSystemsBase v1.10.2
  [687d7614] ControlSystemsMTK v2.1.0
  [adafc99b] CpuId v0.3.1
  [a8cc5b0e] Crayons v4.1.1
  [717857b8] DSP v0.7.9
  [9a962f9c] DataAPI v1.16.0
  [a93c6f00] DataFrames v1.6.1
⌅ [82cc6244] DataInterpolations v4.8.0
  [864edb3b] DataStructures v0.18.20
  [e2d170a0] DataValueInterfaces v1.0.0
  [bcd4f6db] DelayDiffEq v5.47.3
  [8bb1440f] DelimitedFiles v1.9.1
  [a81e2ce2] DescriptorSystems v1.4.1
  [2b5f629d] DiffEqBase v6.151.1
⌅ [459566f4] DiffEqCallbacks v2.37.0
  [77a26b50] DiffEqNoiseProcess v5.21.0
  [163ba53b] DiffResults v1.1.0
  [b552c78f] DiffRules v1.15.1
  [0c46a032] DifferentialEquations v7.13.0
  [b4f34e82] Distances v0.10.11
  [31c24e10] Distributions v0.25.108
  [ffbed154] DocStringExtensions v0.9.3
⌅ [5b8099bc] DomainSets v0.6.7
  [fa6b7ba4] DualNumbers v0.6.8
  [7c1d4256] DynamicPolynomials v0.5.7
⌅ [06fc5a27] DynamicQuantities v0.13.2
  [4e289a0a] EnumX v1.0.4
  [f151be2c] EnzymeCore v0.7.2
  [460bff9d] ExceptionUnwrapping v0.1.10
  [d4d017d3] ExponentialUtilities v1.26.1
  [e2ba6199] ExprTools v0.1.10
  [c87230d0] FFMPEG v0.4.1
  [7a1cc6ca] FFTW v1.8.0
  [9d29842c] FastAlmostBandedMatrices v0.1.1
  [7034ab61] FastBroadcast v0.2.8
  [9aa1b823] FastClosures v0.3.2
  [29a986be] FastLapackInterface v2.0.3
  [48062228] FilePathsBase v0.9.21
  [1a297f60] FillArrays v1.11.0
  [64ca27bc] FindFirstFunctions v1.2.0
  [6a86dc24] FiniteDiff v2.23.1
  [53c48c17] FixedPointNumbers v0.8.5
  [1fa38f19] Format v1.3.7
  [f6369f11] ForwardDiff v0.10.36
  [069b7b12] FunctionWrappers v1.1.3
  [77dc65aa] FunctionWrappersWrappers v0.1.3
  [d9f16b24] Functors v0.4.10
  [46192b85] GPUArraysCore v0.1.6
  [28b8d3ca] GR v0.73.5
  [c145ed77] GenericSchur v0.5.4
  [c27321d9] Glob v1.3.1
  [86223c79] Graphs v1.11.0
  [42e2da0e] Grisu v1.0.2
  [0b43b601] Groebner v0.7.4
  [cd3eb016] HTTP v1.10.8
  [3e5b6fbb] HostCPUFeatures v0.1.16
  [e91730f6] Hungarian v0.7.0
  [34004b35] HypergeometricFunctions v0.3.23
  [7073ff75] IJulia v1.24.2
  [615f187c] IfElse v0.1.1
  [d25df0c9] Inflate v0.1.4
  [842dd82b] InlineStrings v1.4.0
  [18e54dd8] IntegerMathUtils v0.1.2
⌅ [a98d9a8b] Interpolations v0.14.0
  [8197267c] IntervalSets v0.7.10
  [3587e190] InverseFunctions v0.1.14
  [41ab1584] InvertedIndices v1.3.0
  [92d709cd] IrrationalConstants v0.2.2
  [c8e1da08] IterTools v1.10.0
  [82899510] IteratorInterfaceExtensions v1.0.0
  [1019f520] JLFzf v0.1.7
  [692b3bcd] JLLWrappers v1.5.0
  [682c06a0] JSON v0.21.4
  [98e50ef6] JuliaFormatter v1.0.56
  [ccbc3e58] JumpProcesses v9.11.1
  [ef3ab10e] KLU v0.6.0
  [ba0b0d4f] Krylov v0.9.6
  [b964fa9f] LaTeXStrings v1.3.1
  [2ee39098] LabelledArrays v1.16.0
  [984bce1d] LambertW v0.4.6
  [23fbe1c1] Latexify v0.16.3
  [10f19ff3] LayoutPointers v0.1.15
⌅ [5078a376] LazyArrays v1.10.0
  [2d8b4e74] LevyArea v1.0.0
  [d3d80556] LineSearches v7.2.0
  [7a12625a] LinearMaps v3.11.2
  [7ed4a6bd] LinearSolve v2.30.0
  [2ab3a3ac] LogExpFunctions v0.3.27
  [e6f89c97] LoggingExtras v1.0.3
  [bdcacae8] LoopVectorization v0.12.170
  [d8e11817] MLStyle v0.4.17
  [1914dd2f] MacroTools v0.5.13
  [d125e4d3] ManualMemory v0.1.8
  [99c1a7ee] MatrixEquations v2.4.2
⌅ [a3b82374] MatrixFactorizations v2.2.0
  [48965c70] MatrixPencils v1.8.0
  [bb5d69b7] MaybeInplace v0.1.2
  [739be429] MbedTLS v1.1.9
  [442fdcdd] Measures v0.3.2
  [94925ecb] MethodOfLines v0.11.0
  [e1d29d7a] Missings v1.2.0
  [961ee093] ModelingToolkit v9.14.0
  [16a59e39] ModelingToolkitStandardLibrary v2.7.1
  [0987c9cc] MonteCarloMeasurements v1.1.6
  [46d2c3a1] MuladdMacro v0.2.4
  [102ac46a] MultivariatePolynomials v0.5.5
  [d8a4904e] MutableArithmetics v1.4.4
  [d41bc354] NLSolversBase v7.8.3
  [2774e3e8] NLsolve v4.5.1
  [77ba4419] NaNMath v1.0.2
⌅ [2edaba10] Nemo v0.43.3
⌃ [8913a72c] NonlinearSolve v3.11.0
  [6fe1bfb0] OffsetArrays v1.14.0
  [4d8831e6] OpenSSL v1.4.3
  [429524aa] Optim v1.9.4
  [bac558e1] OrderedCollections v1.6.3
  [1dea7af3] OrdinaryDiffEq v6.78.0
  [a7812802] PDEBase v0.1.10
  [90014a1f] PDMats v0.11.31
  [65ce6f38] PackageExtensionCompat v1.0.2
  [d96e819e] Parameters v0.12.3
  [69de0a69] Parsers v2.8.1
  [b98c9c47] Pipe v1.3.0
  [ccf2f8ad] PlotThemes v3.1.0
  [995b91a9] PlotUtils v1.4.1
  [91a5bcdd] Plots v1.40.4
  [e409e4f3] PoissonRandom v0.4.4
  [f517fe37] Polyester v0.7.14
  [1d0040c9] PolyesterWeave v0.2.1
  [f27b6e38] Polynomials v4.0.8
  [2dfb63ee] PooledArrays v1.4.3
  [85a6dd25] PositiveFactorizations v0.2.4
  [d236fae5] PreallocationTools v0.4.21
  [aea7be01] PrecompileTools v1.2.1
  [21216c6a] Preferences v1.4.3
  [08abe8d2] PrettyTables v2.3.1
  [27ebfcd6] Primes v0.5.6
  [43287f4e] PtrArrays v1.1.0
  [1fd47b50] QuadGK v2.9.4
  [74087812] Random123 v1.7.0
  [fb686558] RandomExtensions v0.4.4
  [e6cf234a] RandomNumbers v1.5.3
  [c84ed2f1] Ratios v0.4.5
  [3cdcf5f2] RecipesBase v1.3.4
  [01d81517] RecipesPipeline v0.6.12
  [731186ca] RecursiveArrayTools v3.19.0
  [f2c3362d] RecursiveFactorization v0.2.23
  [189a3867] Reexport v1.2.2
  [05181044] RelocatableFolders v1.0.1
  [ae029012] Requires v1.3.0
  [ae5879a3] ResettableStacks v1.1.1
  [79098fc4] Rmath v0.7.1
  [21fd56a4] RobustAndOptimalControl v0.4.31
  [7e49a35a] RuntimeGeneratedFunctions v0.5.13
  [94e857df] SIMDTypes v0.1.0
  [476501e8] SLEEFPirates v0.6.42
  [0bca4576] SciMLBase v2.38.0
  [c0aeaf25] SciMLOperators v0.3.8
  [53ae85a6] SciMLStructures v1.2.0
  [6c6a2e73] Scratch v1.2.1
  [91c51154] SentinelArrays v1.4.3
  [efcf1570] Setfield v1.1.1
  [992d4aef] Showoff v1.0.3
  [777ac1f9] SimpleBufferStream v1.1.0
  [727e6d20] SimpleNonlinearSolve v1.8.0
  [699a6c99] SimpleTraits v0.9.4
  [ce78b400] SimpleUnPack v1.1.0
  [b85f4697] SoftGlobalScope v1.1.0
  [a2af1166] SortingAlgorithms v1.2.1
⌃ [47a9eef4] SparseDiffTools v2.18.0
  [e56a9233] Sparspak v0.3.9
  [276daf66] SpecialFunctions v2.4.0
  [aedffcd0] Static v0.8.10
  [0d7ed370] StaticArrayInterface v1.5.0
  [90137ffa] StaticArrays v1.9.4
  [1e83bf80] StaticArraysCore v1.4.2
  [82ae8749] StatsAPI v1.7.0
  [2913bbd2] StatsBase v0.34.3
  [4c63d2b9] StatsFuns v1.3.1
⌃ [9672c7b4] SteadyStateDiffEq v2.0.1
  [789caeaf] StochasticDiffEq v6.65.1
  [7792a7ef] StrideArraysCore v0.5.6
  [892a3eda] StringManipulation v0.3.4
  [c3572dad] Sundials v4.24.0
  [2efcf032] SymbolicIndexingInterface v0.3.21
  [19f23fe9] SymbolicLimits v0.2.0
⌃ [d1185830] SymbolicUtils v1.5.1
  [0c5d862f] Symbolics v5.28.0
  [3783bdb8] TableTraits v1.0.1
  [bd369af6] Tables v1.11.1
  [62fd8b95] TensorCore v0.1.1
⌅ [8ea1fca8] TermInterface v0.3.3
  [8290d209] ThreadingUtilities v0.5.2
  [a759f4b9] TimerOutputs v0.5.24
  [0796e94c] Tokenize v0.5.29
  [3bb67fe8] TranscodingStreams v0.10.8
  [d5829a12] TriangularSolve v0.2.0
  [410a4b4d] Tricks v0.1.8
  [781d530d] TruncatedStacktraces v1.4.0
  [5c2747f8] URIs v1.5.1
  [3a884ed6] UnPack v1.0.2
  [1cfade01] UnicodeFun v0.4.1
  [1986cc42] Unitful v1.20.0
  [45397f5d] UnitfulLatexify v1.6.3
  [a7c27f48] Unityper v0.1.6
  [013be700] UnsafeAtomics v0.2.1
  [41fe7b60] Unzip v0.2.0
  [3d5dd08c] VectorizationBase v0.21.67
  [81def892] VersionParsing v1.3.0
  [19fa3120] VertexSafeGraphs v0.2.0
  [ea10d353] WeakRefStrings v1.4.2
⌅ [efce3f68] WoodburyMatrices v0.5.6
  [76eceee3] WorkerUtilities v1.6.1
  [c2297ded] ZMQ v1.2.3
  [e21ec000] Antic_jll v0.201.500+0
  [d9960996] Arb_jll v200.2300.0+0
  [6e34b625] Bzip2_jll v1.0.8+1
  [83423d85] Cairo_jll v1.18.0+2
  [fcfa6d1b] Calcium_jll v0.401.100+0
  [2702e6a9] EpollShim_jll v0.0.20230411+0
  [2e619515] Expat_jll v2.6.2+0
⌅ [b22a6f82] FFMPEG_jll v4.4.4+1
  [f5851436] FFTW_jll v3.3.10+0
⌅ [e134572f] FLINT_jll v200.900.9+0
  [a3f928ae] Fontconfig_jll v2.13.96+0
  [d7e528f0] FreeType2_jll v2.13.2+0
  [559328eb] FriBidi_jll v1.0.14+0
  [0656b61e] GLFW_jll v3.3.9+0
  [d2c73de3] GR_jll v0.73.5+0
  [78b55507] Gettext_jll v0.21.0+0
  [7746bdde] Glib_jll v2.80.2+0
  [3b182d85] Graphite2_jll v1.3.14+0
  [2e76f6c2] HarfBuzz_jll v2.8.1+1
  [1d5cc7b8] IntelOpenMP_jll v2024.1.0+0
  [aacddb02] JpegTurbo_jll v3.0.3+0
  [c1c5ebd0] LAME_jll v3.100.2+0
⌅ [88015f11] LERC_jll v3.0.0+1
  [1d63c593] LLVMOpenMP_jll v15.0.7+0
  [dd4b983a] LZO_jll v2.10.2+0
⌅ [e9f186c6] Libffi_jll v3.2.2+1
  [d4300ac3] Libgcrypt_jll v1.8.11+0
  [7e76a0d4] Libglvnd_jll v1.6.0+0
  [7add5ba3] Libgpg_error_jll v1.49.0+0
  [94ce4f54] Libiconv_jll v1.17.0+0
  [4b2f31a3] Libmount_jll v2.40.1+0
⌅ [89763e89] Libtiff_jll v4.5.1+1
  [38a345b3] Libuuid_jll v2.40.1+0
  [856f044c] MKL_jll v2024.1.0+0
  [e7412a2a] Ogg_jll v1.3.5+1
⌅ [656ef2d0] OpenBLAS32_jll v0.3.24+0
  [458c3c95] OpenSSL_jll v3.0.13+1
  [efe28fd5] OpenSpecFun_jll v0.5.5+0
  [91d4177d] Opus_jll v1.3.2+0
  [30392449] Pixman_jll v0.43.4+0
⌅ [c0090381] Qt6Base_jll v6.5.3+1
  [f50d1b31] Rmath_jll v0.4.2+0
⌅ [fb77eaff] Sundials_jll v5.2.2+0
  [a44049a8] Vulkan_Loader_jll v1.3.243+0
  [a2964d1f] Wayland_jll v1.21.0+1
  [2381bf8a] Wayland_protocols_jll v1.31.0+0
  [02c8fc9c] XML2_jll v2.12.7+0
  [aed1982a] XSLT_jll v1.1.34+0
  [ffd25f8a] XZ_jll v5.4.6+0
  [f67eecfb] Xorg_libICE_jll v1.1.1+0
  [c834827a] Xorg_libSM_jll v1.2.4+0
  [4f6342f7] Xorg_libX11_jll v1.8.6+0
  [0c0b7dd1] Xorg_libXau_jll v1.0.11+0
  [935fb764] Xorg_libXcursor_jll v1.2.0+4
  [a3789734] Xorg_libXdmcp_jll v1.1.4+0
  [1082639a] Xorg_libXext_jll v1.3.6+0
  [d091e8ba] Xorg_libXfixes_jll v5.0.3+4
  [a51aa0fd] Xorg_libXi_jll v1.7.10+4
  [d1454406] Xorg_libXinerama_jll v1.1.4+4
  [ec84b674] Xorg_libXrandr_jll v1.5.2+4
  [ea2f1a96] Xorg_libXrender_jll v0.9.11+0
  [14d82f49] Xorg_libpthread_stubs_jll v0.1.1+0
  [c7cfdc94] Xorg_libxcb_jll v1.15.0+0
  [cc61e674] Xorg_libxkbfile_jll v1.1.2+0
  [e920d4aa] Xorg_xcb_util_cursor_jll v0.1.4+0
  [12413925] Xorg_xcb_util_image_jll v0.4.0+1
  [2def613f] Xorg_xcb_util_jll v0.4.0+1
  [975044d2] Xorg_xcb_util_keysyms_jll v0.4.0+1
  [0d47668e] Xorg_xcb_util_renderutil_jll v0.3.9+1
  [c22f9ab0] Xorg_xcb_util_wm_jll v0.4.1+1
  [35661453] Xorg_xkbcomp_jll v1.4.6+0
  [33bec58e] Xorg_xkeyboard_config_jll v2.39.0+0
  [c5fb5394] Xorg_xtrans_jll v1.5.0+0
  [8f1865be] ZeroMQ_jll v4.3.5+0
  [3161d3a3] Zstd_jll v1.5.6+0
  [35ca27e7] eudev_jll v3.2.9+0
⌅ [214eeab7] fzf_jll v0.43.0+0
  [1a1c6b14] gperf_jll v3.1.1+0
  [a4ae2306] libaom_jll v3.9.0+0
  [0ac62f75] libass_jll v0.15.1+0
  [2db6ffa8] libevdev_jll v1.11.0+0
  [f638f0a6] libfdk_aac_jll v2.0.2+0
  [36db933b] libinput_jll v1.18.0+0
  [b53b4c65] libpng_jll v1.6.43+1
  [a9144af2] libsodium_jll v1.0.20+0
  [f27f6e37] libvorbis_jll v1.3.7+1
  [009596ad] mtdev_jll v1.1.6+0
  [1317d2d5] oneTBB_jll v2021.12.0+0
  [1270edf5] x264_jll v2021.5.5+0
  [dfaa095f] x265_jll v3.5.0+0
  [d8fb68d0] xkbcommon_jll v1.4.1+1
  [0dad84c5] ArgTools v1.1.1
  [56f22d72] Artifacts
  [2a0f44e3] Base64
  [ade2ca70] Dates
  [8ba89e20] Distributed
  [f43a241f] Downloads v1.6.0
  [7b1f6079] FileWatching
  [9fa8497b] Future
  [b77e0a4c] InteractiveUtils
  [4af54fe1] LazyArtifacts
  [b27032c2] LibCURL v0.6.4
  [76f85450] LibGit2
  [8f399da3] Libdl
  [37e2e46d] LinearAlgebra
  [56ddb016] Logging
  [d6f4376e] Markdown
  [a63ad114] Mmap
  [ca575930] NetworkOptions v1.2.0
  [44cfe95a] Pkg v1.10.0
  [de0858da] Printf
  [9abbd945] Profile
  [3fa0cd96] REPL
  [9a3f8284] Random
  [ea8e919c] SHA v0.7.0
  [9e88b42a] Serialization
  [1a1011a3] SharedArrays
  [6462fe0b] Sockets
  [2f01184e] SparseArrays v1.10.0
  [10745b16] Statistics v1.10.0
  [4607b0f0] SuiteSparse
  [fa267f1f] TOML v1.0.3
  [a4e569a6] Tar v1.10.0
  [8dfed614] Test
  [cf7118a7] UUIDs
  [4ec0a83e] Unicode
  [e66e0078] CompilerSupportLibraries_jll v1.1.1+0
  [781609d7] GMP_jll v6.2.1+6
  [deac9b47] LibCURL_jll v8.4.0+0
  [e37daf67] LibGit2_jll v1.6.4+0
  [29816b5a] LibSSH2_jll v1.11.0+1
  [3a97d323] MPFR_jll v4.2.0+1
  [c8ffd9c3] MbedTLS_jll v2.28.2+1
  [14a3606d] MozillaCACerts_jll v2023.1.10
  [4536629a] OpenBLAS_jll v0.3.23+4
  [05823500] OpenLibm_jll v0.8.1+2
  [efcefdf7] PCRE2_jll v10.42.0+1
  [bea87d4a] SuiteSparse_jll v7.2.1+1
  [83775a58] Zlib_jll v1.2.13+1
  [8e850b90] libblastrampoline_jll v5.8.0+1
  [8e850ede] nghttp2_jll v1.52.0+1
  [3f19e933] p7zip_jll v17.4.0+2
Info Packages marked with ⌃ and ⌅ have new versions available. Those with ⌃ may be upgradable, but those with ⌅ are restricted by compatibility constraints from upgrading. To see why use `status --outdated -m`

Hm… I tried with:

julia> Pkg.remove(["Symbolics", "ModelingToolkit"])
julia> Pkg.update()

and get:

How on earth can the Pkg system do precompiling on a package I have removed?

OK – I did have some packages such as MethodOfLines, ControlSystemsMTK, etc. in my set-up. Perhaps they make the Pkg-manager think ModelingToolkit is still on the computer.

I don’t know if it’s the case here but it’s entirely possible that a package which you remove as a direct dependency may still be an indirect dependency of some other package.

It might be easier to start a new environment just for Oscar.

Also I note that Oscar says it requires WSL for use on Windows:

Please install Windows Subsystem for Linux (WSL) following the official instructions. You should now have an App “Ubuntu” in your start menu (run “explorer.exe .” in the Ubuntu terminal to open the current folder in the Windows File Explorer). You can now follow the instructions for Ubuntu .

I removed all packages, and started adding from scratch from my list above…

It went fine until I came to ModelingToolkit. This package makes the compiler hang again.

I’m trying once more to remove everything, this time adding ModelingToolkit first…

It seems like ModelingToolkit takes forever to compile, even if it is the only package I have. There seems to be 26 “steps” in the compilation, and the compiler hangs on 25/26.

Can the attempt to install Oscar.jl have messed up my system?

  • Should I uninstall Julia, delete packages on disk, and re-install Julia from scratch??

Rather than removing everything, the easier thing would have been creating a new environment, perhaps temporary. For example you could have done the following.

using Pkg
Pkg.activate(; temp = true)

Let’s now focus on the current problem: ModelingToolkit.jl does not precompile.

This is usually not a great solution because you never figure out how to fix the issue.

At most you might want to consider removing or renaming the following directory.


My other recommendation is that you may want to create a new topic, specifically mentioning ModelingToolkit.jl in the title, which attract the SciML folks.

Moreover, I do want to emphasize that Oscar does not install directly on Windows. You must use WSL.

Hi. I’m having the same issue. I can install everything but when it comes to compile ModelingToolkit, it stops. Did you solve your problem? I am trying in 3 different PCs but it always happens

Not yet.

Let me know if you find a way to fix this. Im discussing this on Slack so ill keep you informed too

@ChrisRackauckas There might be an issue with ModelingToolkit.jl precompilation on Windows. See above.

Ok, let’s try to install an older version of ModelingToolkit.jl.

using Pkg
Pkg.activate(; temp = true)
Pkg.add(name="ModelingToolkit", version="9.13")

If that does not work try 9.12, 9.11, 9.10, etc.

I tried MTK 9.0.0. Doesn’t precompile. It worked in the past (although I installed it under Julia 10.0 or something).

If you could, try Julia 1.10.2 and Julia 1.10.1.

If you are using juliaup, you can do

juliaup add 1.10.2
julia +1.10.2

No luck with Julia v1.10.2. (I waited 20 minutes…).

Am now trying with Julia v1.10.0

Same problem on windows 10, this is not a specific windows 11 issue. I’ve also with several latest stable versions of MTK (9.12-9.14).

No luck. I have now tried with Julia v10.3 and ModelingToolkit [MTK] latest version + MTK v9.13.0 and MTK v9.0.0. I have also tried with Julia v10.2 and the same versions of MTK, as well as Julia v10.0 and the same versions of MTK.

Still no luck – ModelingToolkit will not finish precompilation.

What could be wrong?

  • Something special with the set-up of Windows PCs for those who have reported problems?
  • Something wrong with ModelingToolkit on the server – assuming we fetch MTK from the same server? [OK – not likely?]
  • Other things?

I can report that rolling back OrdinaryDiffEq to v6.75.0 fixes the problem. Whichever environment you are in, add and pin that version and ModelingToolkit should then finally pre-compile.