ModelingToolkit doesn't precompile any more

A few days ago, I installed some new packages (AbstractAlgebra, Nemo, Groebner). I also tried to install Oscar. When I tried to compile Oscar, I was told it doesn’t run on Windows, and I removed it.

Since then, ModelingToolkit doesn’t precompile. I don’t know whether there is a conflict with the above mentioned installations/attempts of installation, or whether the problem is due to some new versions of ModelingToolkit.

I have tried to remove all packages and re-install them. Problem persists. I have tried to remove all packages, and only install MTK. Problem persists… Precompilation of MTK hangs in the last step (222/223 with a fresh installation), and hangs for like 8-12 hours before I have given up.

I have now uninstalled Julia, deleted the .julia directory, restarted computer, checked that Julia is not on it, downloaded the Julia app and reinstalled Julia v10.3, and started to add MTK again.

Again, precompiling until step 222/223 went fine; now it is hanging again. So far for 20 minutes…


  1. Anyone has got a clue of what has gone wrong? [Latest version of Win 11, 1TB free disk space, 32 GB RAM, 12th gen intel]
  2. How long time should I expect the precompilation to take? [I know it is a big package]

Here ModelingToolkit installation/precompilation took:

  1. ~2 minutes after add ModelingToolkit
  2. using ModelingToolkit for the first time, precompiled again (?) and took about 5 minutes.
  3. On restarting Julia in the same project, using ModelingToolkit precompiled again (?) and took more 2 minutes.
  4. On restarting Julia again, using ModelingToolkit took ~3s.

AbstractAlgebra, Nemo, Groebner and took about 1 minute to install.

julia> versioninfo()
Julia Version 1.10.3
Commit 0b4590a5507 (2024-04-30 10:59 UTC)
Build Info:
  Official release
Platform Info:
  OS: Linux (x86_64-linux-gnu)
  CPU: 20 × 12th Gen Intel(R) Core(TM) i7-12700F
  LIBM: libopenlibm
  LLVM: libLLVM-15.0.7 (ORCJIT, alderlake)
Threads: 1 default, 0 interactive, 1 GC (on 20 virtual cores)

There is a known issue as of yesterday. Please keep the reports to one thread


1.10.4 has been released which fixes this bug Julia v1.10.4 has been released