Bug in Julia or in a package

The following bug was closed with the comment it would be a Julia bug:

I am not convinced that this is a bug in Julia, I think it is a bug in a package. What do you think?

Maybe its `PrecompilableError` thrown outside of `__precompile__(false)` cases Β· Issue #51299 Β· JuliaLang/julia Β· GitHub

Thanks for the link, but it does not really answer my question…

If you search the issues list you’d see that you’re the 8th one to post it this week, and the answer is still the same. It doesn’t cause any actual errors, it’s precompilation errors with SymbolicsForwardDiffExt and SymbolicsPreallocationToolsExt Β· Issue #1042 Β· JuliaSymbolics/Symbolics.jl Β· GitHub, and it’s due to a bug in Julia Extensions: pre-compilation fails if more than one extension Β· Issue #52511 Β· JuliaLang/julia Β· GitHub. I’ll work around it so the printing and all goes away, but I cannot actually work around it if I need to keep pasting this information.

1 Like

Should be completely gone now. Worked around it by making ForwardDiff a dependency to Symbolics, and it’s setup to be easy to be made back into an extension with Julia v1.11 which should have the fix.