Mac installation totally busted

I tried to install Julia 1.5.2 on my Mac, but there is a typo in the script:

igor@Igors-MacBook-Pro ~ % xec ‘/private/var/folders/tx/3vwvrf2n56502g3fbglg7csw0000gn/T/AppTranslocation/A7E0A413-761B-4EF0-A31B-09ECD37DFC68/d/’

zsh: command not found: xec

apparently you had dropped the first “e” in exec.

I then tried JuliaPro, which does run, BUT, when I try to add IJulia, I get:

@JuliaPro_v1.5.2-1) pkg> add IJulia
Resolving package versions…
ERROR: expected package PkgAuthentication [4722fa14] to be registered

IJulia comes with Julia Pro IIRC

Sorry, I don’t know what that means, perhaps you can elaborate.

you don’t need to install IJulia, you can just using IJulia

1 Like

Why didn’t you just use the standard binary install ? (That link is from the main website)

Also if there’s a typo in a suggested script somewhere, people will certainly appreciate it if you open an issue at the repo where you found the instructions (here your message is unlikely to be seen by maintainers, especially with such a title)