Luxor and Julia Can they dance?

All:

    I am exited to learn all I can with Julia and my reach focus, Luxor.

I am building this out on Windows 10, 64-bit. I downloaded the current and most stable version
of Julia, activated the prompt and run several Julia commands with no hitch.(SFSG).
Emboldened, I next from the Julia command prompt, followed the command line
instructions to download and install Luxor. After I keyed in the necessary commands,
the computer took over and begin a Linux like package install in which there were
a hundred status messages indicating various stages of the Luxor install. On closer
inspection of the command line output about 10% of the output had some sort of
errors, could not find module, could not find directory, etc.
I was advised this might be a Windows Powershell issue and realized the
PowerShell is the most current and up to date.
What seems to be the hitch ??? Should I switch to a Mac machine and retrace
my initial steps ??

    Mason Yu Jr., computer graphics aficionado

Hello Again! I think you posted a month ago on Reddit. Welcome (back)!

I’m sorry to hear that you’ve not made much progress… But the advice is the same: these error messages are important, and will allow you (and us, when we know what they are) to diagnose what the problems are, and how they might be solved.

It’s true, as someone observed on Reddit on your post, that Windows installations can be difficult. I’m not sure why that is, but that’s because I don’t use Windows myself. But others do, and you should receive help if you state your problems clearly.

Problems with a particular package specifically are better described in an issue on the GitHub repository for that package—you’re more likely to catch the author’s attention there,

1 Like

@computerhoncho I use Windows 10 and I can help test the same installation.

Julia 1.1.1
pkg> add Luxor succeeds
pkg> test Luxor and there are warnings about a missing font called Georgia
That is not serious of course
I would suggest to @computerhoncho to install Julia 1.1.1 and try again!

1 Like

Georgia’s always on my mind… :slight_smile: I wonder whether there are any fonts that are guaranteed to be available on all three platforms… Julia Sans anyone?

Thanks for the testing!

Pasting these error messages here (please quote your code) would very likely get you quick help. Conversely, without the exact messages, there is little we can do.

2 Likes

Will do… thank you for your kind response …

v1.1) pkg> add Luxor
Cloning default registries into C:\Users\compu\.julia
Cloning registry from “https://github.com/JuliaRegistries/General.git
ERROR: SystemError: opening file “C:\Users\compu\.julia\registries\General\Registry.toml”: No such file or directory
Stacktrace:
[1] #systemerror#43(::Nothing, ::Function, ::String, ::Bool) at .\error.jl:134
[2] systemerror at .\error.jl:134 [inlined]
[3] #open#309(::Bool, ::Nothing, ::Nothing, ::Nothing, ::Nothing, ::Function, ::String) at .\iostream.jl:289
[4] #open at .\none:0 [inlined]
[5] open(::String, ::String) at .\iostream.jl:345
[6] #open#310(::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::typeof(Pkg.TOML.parse), ::String, ::Vararg{String,N} where N) at .\iostream.jl:373
[7] open at .\iostream.jl:373 [inlined]
[8] parsefile at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\ext\TOML\src\TOML.jl:46 [inlined]
[9] #read_registry#91(::Bool, ::Function, ::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Types.jl:1149
[10] read_registry at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Types.jl:1144 [inlined]
[11] clone_or_cp_registries(::Pkg.Types.Context, ::Array{Pkg.Types.RegistrySpec,1}, ::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Types.jl:1121
[12] clone_or_cp_registries at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Types.jl:1087 [inlined]
[13] clone_default_registries() at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Types.jl:1037
[14] find_registered!(::Pkg.Types.EnvCache, ::Array{String,1}, ::Array{Base.UUID,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Types.jl:1312
[15] registry_resolve!(::Pkg.Types.EnvCache, ::Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Types.jl:949
[16] #add_or_develop#17(::Symbol, ::Bool, ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\API.jl:52
[17] (::getfield(Pkg.API, Symbol("#kw##add_or_develop")))(::NamedTuple{(:mode,),Tuple{Symbol}}, ::typeof(Pkg.API.add_or_develop), ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at .\none:0
[18] do_add!(::Dict{Symbol,Any}, ::Array{Pkg.Types.PackageSpec,1}, ::Dict{Symbol,Any}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\REPLMode.jl:672
[19] #invokelatest#1(::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Any, ::Any, ::Vararg{Any,N} where N) at .\essentials.jl:742
[20] invokelatest(::Any, ::Any, ::Vararg{Any,N} where N) at .\essentials.jl:741
[21] do_cmd!(::Pkg.REPLMode.PkgCommand, ::REPL.LineEditREPL) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\REPLMode.jl:563
[22] #do_cmd#31(::Bool, ::Function, ::REPL.LineEditREPL, ::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\REPLMode.jl:538
[23] do_cmd at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\REPLMode.jl:534 [inlined]
[24] (::getfield(Pkg.REPLMode, Symbol("##53#56")){REPL.LineEditREPL,REPL.LineEdit.Prompt})(::REPL.LineEdit.MIState, ::Base.GenericIOBuffer{Array{UInt8,1}}, ::Bool) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\REPLMode.jl:988
[25] #invokelatest#1 at .\essentials.jl:742 [inlined]
[26] invokelatest at .\essentials.jl:741 [inlined]
[27] run_interface(::REPL.Terminals.TextTerminal, ::REPL.LineEdit.ModalInterface, ::REPL.LineEdit.MIState) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\REPL\src\LineEdit.jl:2273
[28] run_frontend(::REPL.LineEditREPL, ::REPL.REPLBackendRef) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\REPL\src\REPL.jl:1035
[29] run_repl(::REPL.AbstractREPL, ::Any) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\REPL\src\REPL.jl:192
[30] (::getfield(Base, Symbol("##734#736")){Bool,Bool,Bool,Bool})(::Module) at .\client.jl:362
[31] #invokelatest#1 at .\essentials.jl:742 [inlined]
[32] invokelatest at .\essentials.jl:741 [inlined]
[33] run_main_repl(::Bool, ::Bool, ::Bool, ::Bool, ::Bool) at .\client.jl:346
[34] exec_options(::Base.JLOptions) at .\client.jl:284
[35] _start() at .\client.jl:436

(v1.1) pkg>

I then tried using Luxor; did not work

The above error message is not related to Luxor at all. Pkg can’t install it for some reason. To debug that, please open a new topic with the error message (and again, please quote your code).

Can you install other packages?

Try delete the folder C:\Users\compu\.julia\registries\General and add again.