ANN: Julia 0.6.1 is here!

release

#1

Julia v0.6.1, the first patch version in the 0.6 series of releases, is now available! As a patch release, it’s intended to be non-breaking, so we recommend that everyone on 0.6.0 upgrade to get the latest bugfixes. You can see the list of commits included in 0.6.1 since 0.6.0 here.

As usual, downloads are available on Linux, macOS, and Windows. While the nightlies have included it for a while, 0.6.1 is the first release version to include official Linux binaries for ARMv8 (also known as AArch64).

Get binaries for your platform while they’re hot: https://julialang.org/downloads/


#2

It seems the website is not updated. Still points to v0.6.0.


#3

Ok, it just changed now :smile:


#4

Excellent! Although I’m still waiting for 0.6 to be available via apt-get on Mint…


#5

We recommend against installing Julia via system package managers. Indeed, we have the following in the Julia README:

Note: While some system package managers have Julia installers available, these are not maintained nor endorsed by the Julia project. They may be outdated and/or unmaintained. We recommend you use the official Julia binaries instead.


#6

Alex - thank you for preparing and publishing the release!


#7

Great, thank you for all the work, everyone!

Can I take this opportunity to shamelessly ask for binaries for ppc64le, they have disappeared from the website since 6.0-rc3? :slight_smile:


#8

Hi Rami,

As stated before, we’ve lost access to our Power machines that we needed to build and support those binaries. If you are a customer of Power machines, it may be worthwhile to ask your sales contacts if they can assist somehow.

Regards

Avik


#9

I downloaded the 64 bit version of Julia 0.6.1 for Windows. I tried to install it as Administrator, but failed: the system says: “Administrator blocked you from running this app.” I could install it in my own local folder without running it as Administrator. But if possible, I want to install it by running as Administrator in the system wide folder C:\Program Files.
Does this .exe installation file have something wrong? I didn’t have any problem installing both versions 0.5.2 and 0.6.0 as Administrator. In fact, I just tried to install 0.5.2 by downloading it now, and I could install it as Administrator without any problems.
By the way, the same thing happens for 32 bit version.
Thank you very much for your help!
BVPs


#10

When building from source, if I do not select USE_SYSTEM_LIBUNWIND=1 in Make.user, I get a Make error 22 due to 403 for libunwind. I hope the 403 is a temporary error; otherwise, please consider fixing the dependency.

EDIT. Also related to Julia compile failing with 403 Forbidden


#11

I cannot run the Windows installers because of the error message below. The installer for the nightlies works.

nope

EDIT: I “fixed” it by doing: Right-click -> Properties -> Unblock. I hate Windows :-1: Have not had this problem before, though.


#12

I had this several times with different julia versions on my company, work laptop on Win7/10.


#13

Had the same problem, but just decided to unblock it and go through with it.


#14

Does anyone else get an “Access Denied” message when trying to access the SHA256 checksums (https://julialang-s3.julialang.org/bin/checksums/julia-0.6.1.sha256)? I’ve attached a screenshot of the message:


#15

Why hate it?
It functions properly, notifying you the application you’re trying to run isn’t signed properly and its source can not be validated.
This is the reasonable default behavior, don’t let unsigned / signed by unknown source applications to run.


#16

First of all thanks to everyone who contributed to julia and julia-0.6.1!

I am having a bit of trouble, though. Building from the git source on Linux fails

git clone git://github.com/JuliaLang/julia.git
mv julia julia-0.6.1; cd julia-0.6.1
git checkout v0.6.1
make

after chugging away a long time with error

/usr/bin/install -c -m 644 libuv.pc '/home/gibson/gitworking/julia-0.6.1/usr-staging/libuv-52d72a52cc7ccd570929990f010ed16e2ec604c8/home/gibson/gitworking/julia-0.6.1/usr/lib/pkgconfig'
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   339  100   339    0     0   2882      0 --:--:-- --:--:-- --:--:--  2897
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 403 Forbidden
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 403 Forbidden
/home/gibson/gitworking/julia-0.6.1/deps/unwind.mk:7: recipe for target '/home/gibson/gitworking/julia-0.6.1/deps/srccache/libunwind-1.1-julia2.tar.gz' failed
make[1]: *** [/home/gibson/gitworking/julia-0.6.1/deps/srccache/libunwind-1.1-julia2.tar.gz] Error 22
Makefile:85: recipe for target 'julia-deps' failed
make: *** [julia-deps] Error 2

#17

Point taken.

What is bothering me is the inconsistencies in the OS. One usually gets a Windows 10 style SmartScreen dialog if the executable is not properly signed. This Windows 7 style dialog I have never seen before, the publisher field is empty, and the “How do I unblock this publisher?” link is dead and leads to the generic Windows help page.

@ararslan: Windows says the “certificate was explicitly revoked by its issuer”. This probably needs to be fixed.

nope1


#18

Another possibility is to run the installer from git bash.


#19

I believe this one is taken care of now.


#20

It is hopefully fixed. If it is, I have follow-up problems from overriding this the last time.

“The publisher has been blocked from running programs on the computer”.
Publisher: Unknown publisher.

image

This is on Windows 10 version 1703 OS build 15063.674.

P.S. Just downloaded 0.5.2 64-bit for the first time. The publisher is Julia Computing (which is not banned).