[Linux] .jl files are identified as "plain text documents"

On windows, I chose to open .jl files in VSCode and .txt files in notepad.

I have installed linux, and now when i change the default program for .jl files, it also changes for .txt files, as both are identified as “plain text documents”:

How do I make my system treat them differently?

name@name-ThinkPad-L390:~/GeekyStuff/Julia$ hostnamectl
 Static hostname: name-ThinkPad-L390
       Icon name: computer-laptop
         Chassis: laptop
      Machine ID: b0d275fb46fa48c6820be57edaa22cf5
         Boot ID: 3e03cae2bd9a4dc18ef5840574f56f0f
Operating System: Linux Mint 21                   
          Kernel: Linux 5.15.0-48-generic
    Architecture: x86-64
 Hardware Vendor: Lenovo
  Hardware Model: ThinkPad L390

You can create a file type for .jl files, and associate it with the editor of your choice. I don’t know what desktop Linux Mint uses, so the way to do it will depend on that. If it’s KDE Plasma, you can do it like this, using System Settings → Applications → File Associations.