Juno works great now


#1

I’ve been trying Juno on and off over the last year, and every time I gave up because I’d run into some error when trying to use the Julia features. I write code in Atom but just use the REPL to run it.

Today I tried Juno again, and everything worked including the console, workspace, and plots tabs. The autocomplete is smart. The Gallium debugger works, and the interface coupled with the workspace tab is a lot more informative than my previous attempts to use it in the REPL.

This is really valuable for convincing my friends who are used to MATLAB to try Julia.


#2

Which version? juno-0.5.1?


#3

Julia 0.5.1, the julia-client package in Atom is at 0.5.12


#4

I’m still waiting for ^C to work on Macs…


#5

Hm, interrupts work fine for me on Fedora (and Windows, which is kinda besides the point since it’s implemented differently anyways). How does ^C fail for you? Does it just kill Julia, or does it not interrupt Julia? Also, are you on Julia 0.5 or 0.6?


#6

This is a long standing known issue, that is apparently caused by Julia’s handling of SIGINT. It may be fixed in 0.6.

julia> versioninfo()
Julia Version 0.5.1
Commit 6445c82 (2017-03-05 13:25 UTC)
Platform Info:
  OS: macOS (x86_64-apple-darwin16.4.0)
  CPU: Intel(R) Core(TM) i7-3820QM CPU @ 2.70GHz
  WORD_SIZE: 64
  BLAS: libgfortblas
  LAPACK: liblapack
  LIBM: libopenlibm
  LLVM: libLLVM-3.7.1 (ORCJIT, ivybridge)