Juno is not picking up JULIA_DEPOT_PATH environment variable

question

#1

I’m on Linux Mint and just installed Atom/Juno afresh. When I open Atom from the menu, it doesn’t pick up the JULIA_DEPOT_PATH environment variable. If I open the Juno REPL, it proceeds to install Atom.jl, Juno.jl, etc. to the default depot location, under $HOME/.julia/....

If I open atom from the terminal instead, it does pick up the value of JULIA_DEPOT_PATH and realizes that I have all these things already installed.

I have zsh, and I am exporting JULIA_DEPOT_PATH in my .zshrc file. Any idea of how I can get the Atom from the menu to pick up my depot path? Perhaps there is a special setting for Juno?


#2

Either start Atom via zsh or set the environment variable globally.

You could also put something like

process.env['JULIA_DEPOT_PATH'] = 'path'

into your startup file in Atom (~/.atom/init.coffee or Application: Open your init script in Atom) and that’ll make sure that Julia knows about the environment variable regardless of where you start it from.


#3

Thanks that works!