Jump to error in source code in Juno REPL?

#1

This seems to be a basic operation but I couldn’t find it in the documentation or Internet… So here I am.

In Juno, if I run a script and there are errors, the REPL will show the error message together with the locations of the error in the source code (and obviously there is a Stacktrace of locations at various call levels, not just a single location).

If I hover my mouse over the location, it will be underlined as if it’s a clickable link. But when I click it, nothing happens, the editor does not navigate to the source code location like most other IDEs would do.

I tried Ctrl-click, Alt-click, Ctrl-Alt-click, double click, right click… Same result.

Am I missing something? Thanks for any help!

Versions: Windows 10 64-bit, Atom 1.35.1 x64, Julia 1.1.0 64-bit, Juno.jl v0.7.0, Atom.jl v0.8.2.

#2

That sounds like a bug. Can you post a screenshot, or at least the paths for which this does not work? Also try something like 0//0 in the REPL and try clicking the ./rational.jl part.

#3

Thanks for quick reply!

I tried both in REPL and in script the “0//0” expression, and I was able to click and navigate to the error location in ./rational.jl.

However, for the script case, I was not able to click and navigate to the location in my own script where the error occurred.

Please see screenshot below. The mouse shows where I clicked but was not able to incur any navigation action in my own script “test.jl” which was open in the editor.

#4

Fixed here. I inadvertently messed up the Windows part of some weird regex…
Thanks for the report!

PS: It’s a bit easier for me to keep track of issues if you post them in the Juno.jl repo instead of the forums.

#5

Great! Thank you for the fix!

I’m sometimes reluctant to open issues because I’m often not sure if it’s myself doing something wrong or being unaware of a trick.That’s why I come here to ask. :slight_smile:

Maybe next time I’ll open an issue at the same time and refer to the issue when I ask here. If it turns out it’s not a real issue then I will go back to close it.

Thanks again!

#6

If you’re unsure what’s going on that is an issue as well – not a bug, maybe, but a UX problem.

#7

Good point. :joy: