Julia on Windows Store/juliaup?

I’m trying to install Julia from Windows Store on a new laptop running Windows 11 Pro.

The installation seems to work, and “Install” changes to “Open” in Windows Store. However…

  • If I click on “Open”, nothing happens
  • If I open the Terminal window and run juliaup, the terminal responds with the options of juliaup.
  • If I run juliaup update, I am told there are now channels.
  • If I execute julia in the terminal window, nothing happens
  • If I go to the app list, I find Julia there, but clicking on it leads to no response.

In summary, it seems like Julia doesn’t get installed.

What is wrong? [Could it be that the installation does not have administrative rights? Something else?]

Run juliaup add release in a Terminal window, this will add a Julia version - the release one, that is v1.8.3.

(I don’t understand why it did not add it at Juliaup installation, but it should be easy to repair)

Check with juliaup status

Good luck!

1 Like

Thanks, that worked. Weird: I thought I had tried juliaup add 1.8.3

With juliaup list you will see the list of available versions. On my computer the release version is 1.8.3+0.x64.linux.gnu - a recent change to Juliaup added architecture, os,compiler to the version string. I then would suppose 1.8.3 is now not sufficient to specify the version, you should add those to disambiguate ?

1 Like