How to update Julia in Juliaup?

I’m using Juliaup in my Windows OS, and now I’m waiting for Julia 1.8.1 to be installable by Juliaup. In their Github, they stated that juliaup update should do the job and update the installed Julia to the latest release available. But when I enter that command, nothing is printed. Also, I can’t even run Juliaup as a stand-alone application in my OS:

When I click on it, nothing happens. I can solely reach out to Juliaup using my Terminal by starting with Juliaup ....

  1. Why Juliaup application doesn’t show up when I click on it? I expect a specific terminal at least.
  2. for god’s sake, how can I update Julia using Juliaup? Explain like I’m 7.
1 Like

Hi, a fellow juliaup user here. There is some delay between juliaup’s Github repository and Windows store. Right I’m still on juliaup 1.7.22 (with Julia 1.8.0) while it’s 1.7.23 (with Julia 1.8.1) at GitHub.

  1. juliaup (often) requires a terminal APP (e.g. Windows terminal) to run its commands. (To see its available commands, just type juliaup in Windows terminal)
  2. To update the Julia version, type juliaup update. To update juliaup itself, type juliaup self update.
1 Like

So you mean that I should be patient a bit more?
And I concluded that I don’t need Microsoft Store at all, and I can update those things just by using Terminal. Am I right?

Ok, I understand that the delay due to Windows store impacts the juliaup version that you could download from it.
But if it’s getting the julia version from (according to, then it is more a matter of uploading v1.8.1 to the s3 sever, correct?
That’s the paradox of speed: the faster something is, the more impatient we get :slight_smile:

@Barget I’m not the developer of juliaup (@davidanthoff is); however, according to its commit history, the available Julia versions are tied to how recent juliaup is. (Like this one) So it
seems like older juliaup gets older Julia. You can type juliaup list in the terminal to see available Julia versions.

@Shayan I tried juliaup self update myself (on Windows). Still no updates. I have to wait for the newer juliaup available on Windows Store, too.
Edit: According to this post, running juliaup self update is equivalent to going to the Windows Store and clicking the update button.


Thanks for the explanation.
I admit this kind of version coupling is a bit suprising to me, but I’m sure there’s some good reasons for that (be they technical or practical).

1 Like


1 Like

Short version is: yes, there is a delay and I’m working on a solution where we can get rid of that.