Julia Language Server won't start

I’m new to VSCode, just moving my Julia work over from Juno. I’m having trouble getting the Julia extension to work on Windows 10.

When I install the extension, I have the executable path set up, and I select inline results. Upon opening a Julia script, I can successfully run code in the REPL (i.e. if I run code with Ctrl+Enter the code runs fine in the REPL), but I can’t get the inline to work. I get the following printed to the Terminal:

[ Info: Precompiling VSCodeServer [9f5989ce-84fe-42d4-91ec-6a7a8d53ed0f]

Running anything with Alt+Enter I get the following error box pop up on the bottom rigth:

Error: Julia Language server is not running. Please wait a few seconds and try again once the Starting Julia Language Server… message in the status bar is gone. error message, and I can see the Starting Julia Language Server...

The trouble is, the ‘Starting Julia Language Server…’ message never goes away and the server never starts.

I’ve tried uninstalling (fully) both VSCode and Julia multiple times, but I can’t figure out what the problem is. Any insights? I’ve left the Language Server to start overnight, but it just never started.

Versions:

Julia: Version 1.5.3 (2020-11-09)

VSCode:
Version: 1.51.1 (user setup)
Commit: e5a624b788d92b8d34d1392e4c4d9789406efe8f
Date: 2020-11-10T23:34:32.027Z
Electron: 9.3.3
Chrome: 83.0.4103.122
Node.js: 12.14.1
V8: 8.3.110.13-electron.0
OS: Windows_NT x64 10.0.18363

Thanks in Advance!!!

UPDATE: I’ve replicated the problem on a completely different Windows 10 machine that had neither VSCode nor Julia installed prior, so I don’t think it’s a problem with any old versions etc.

I have actually just encountered the same problem. After several tries with different versions of Julia which did not help, I think I have a solution:

First, you need to “use” Julia so that all the usual directories (registries, etc.) are created. Just start the Julia REPL, go to Pkg mode (with “]”) and add any package. After that try starting VS Code again, hopefully after a moment the server will start.

2 Likes

Amazing, this also worked for me! I tried it on another machine just using Pkg.add() and that didn’t work, so your point about going into Pkg mode was the key. Thanks!