Julia Language Server failed to precompile


I’ve tried to install Julia 1.9.3 on my Mac OS Mojave 10.14.6 (previously using Julia 1.8.5 that perfectly worked).
I use VScode as editor, but now with Julia 1.9.3, VScode Julia language server fails precompiling and crash with error messages like :

The Language Server failed to precompile.
Please make sure you have permissions to write to the LS depot path at
/Users/baisset/Library/Application Support/Code/User/globalStorage/julialang.language-julia/lsdepot/v1

┌ Error: Some Julia code in the VS Code extension crashed
└ @ Main ~/.vscode/extensions/julialang.language-julia-1.50.1/scripts/error_handler.jl:15
ERROR: Failed to precompile LanguageServer [2b0e0bc5-e4fd-59b4-8912-456d1b03d8d7] to “/Users/baisset/Library/Application Support/Code/User/globalStorage/julialang.language-julia/lsdepot/v1/compiled/v1.9/LanguageServer/jl_yvyGKP”.

Does anyone have an idea of how to solve the problem, as I have to use Julia 1.9 in order to run codes that require last version of Makie (which requires Julia 1.9) ?

Thank you,

This problems looks similar to what is described here.
It seems that there is a conflict between Julia v1.9 and VScode language server on older macs. I would not know a solution though…

Yes you’re right the problem looks similar to that one but no solutions have been found for it…
I tried to uninstall VSCode (in a very clean way, deleting “Code” and “~/.vscode” hidden folders in my computer) and install it again but the problem persists.
It is strange because I now have installed the latest version of VSCode (1.81.1) with the latest version of Julia (1.9.3), so I do not understand why it is not working only because my Mac is old (2019 ! Obsolescence is a fast process…)

Sorry to hear you that it still doesn’t work. You could try reaching the language server developers via github.

You are right. I’m gonna do that, thanks.

In my case the problem disappeared after an OS update, see there - maybe this could also help you?