Julia has exited. Press Enter to start a new session

Hello,

I installed Julia, Atom and Juno-lab on Windows 10 following the steps on the Juno website.
Julia is working but not in Atom.
When I try to use Julia in atom in the REPL this is what I got:

Press Enter to start Julia.

(I press enter)

Julia has exited. Press Enter to start a new session.

My version of Atom: 1.40.1 x64
My version of Julia: 1.2.0 (2019-08-20)

This is the details of the errors I have from the console I have (accessing it with CTRL + SHIFT + I):

1st error :

local.coffee:115 Julia exited with Error: Error launching WinPTY agent: agent executable does not exist: ‘\?\C:\Users\MyUserName.atom\packages\julia-client\node_modules@pfitzseb\node-pty-prebuilt\build\Release\winpty-agent.exe’.
(anonymous) @ local.coffee:115

2nd error:

C:\Users\MyUserName.atom\packages\julia-client\node_modules@pfitzseb\node-pty-prebuilt\lib\windowsPtyAgent.js:53 Uncaught (in promise) Error: Error launching WinPTY agent: agent executable does not exist: ‘\?\C:\Users\MyUserName.atom\packages\julia-client\node_modules@pfitzseb\node-pty-prebuilt\build\Release\winpty-agent.exe’
at new WindowsPtyAgent (C:\Users\MyUserName.atom\packages\julia-client\node_modules@pfitzseb\node-pty-prebuilt\lib\windowsPtyAgent.js:53)
at new WindowsTerminal (C:\Users\MyUserName.atom\packages\julia-client\node_modules@pfitzseb\node-pty-prebuilt\lib\windowsTerminal.js:49)
at Object.spawn (C:\Users\MyUserName.atom\packages\julia-client\node_modules@pfitzseb\node-pty-prebuilt\lib\index.js:29)
at basic2.js:93
at process._tickCallback (internal/process/next_tick.js:68)

The thing is that I don’t use NodeJS nor have it installed (it does not appear in the Programs File list). I am using Python for University.
I installed Anaconda too.
The default Python version of my Windows 10 is Python 2.7.10
With Anaconda, I have 2 Python envs both at 3.7.3

Thank you for your attention!

I suspect that your antivir software removed the winpty-agent.exe Juno needs for its REPL. What antivir are you using, and can you access its logs?

2 Likes

I used BitDefender before, but since the licence expired I am using Avast.
I suspect that this BitDefender that removed the file and since I have deleted it to change to Avast I think there is no way I can access to it’s log.
Is there a way I can repair this ?

It was Avast.
Thank you for your help!
The file was put in quarantine.
This is the detail of the file put in the quarantine:
“file infected”: spawnInterruptible.ps1
“Original file location”: C:\Users\UMyUserName\.atom\packages\julia-clients\script

To add description to the issue I had:
The first time I launched Atom the REPL worked but was very slow. That was after closing Atom and reopen it that the REPL could not work. By checking the quarantine in the antivirus as pfitzseb told me, I found that my antivirus disabled some functionality of Atom by putting a file in quarantine.

I did not saw this because my antivirus is working with notifications turned off.

Hi, the spawnInterruptible.ps1 file should now be whitelisted in Avast, so it should work without problems now.

Oh really? Neat.

Note that we got rid of that file in the newest Juno version, so this particular failure mode isn’t really relevant going forward.

Hi, I’m recently experiencing a similar issue with Atom v0.12.14 and Juno v0.8.2 on Julia 1.4.2: I can’t run Julia in the Juno repl (I get the exact same message: Julia has exited. Press Enter to start a new session.) but I can boot Julia within an External terminal.
I have no other antivirus than windows defender so it’s unlikely that this is the cause of the issue.

Please take a look at this and this.

Hi, I had the same problem (on Windows 10). Solution was (as mentioned in the link that pfitzseb posted), to update Atoms ink to version 0.12.4 (together with the current julia-client 0.12.5)

I’ve been busy lately, sorry for the late answer. Indeed, your suggestion correct my problem, many thanks !