Julia autocompletion not working in VSCode

I returned to programming after a few months. VScode seems to have changed. I can’t use Julia with the autocompletion anymore! Please help!!!


I checked whether they work for python to make sure the problem is with Julia alone and yes, it works…

How did you install Julia? Which version of Julia are you using?
Best way is is to use juliaup because it also sets up the paths for VSCode automatically.

Are you working with local environments? If yes, what is in your environment?
What is the output of:

julia --project
using Pkg

Finally, which version of the Julia extension of VSCode are you using?

Also try clicking on the Julia: Starting Language Server in the status bar, which should take you to the “Output” panel. There might be some error messages in there (or you may just need to be patient).

C:\Users\DELL\.julia\environments\v1.9"\Project.toml (empty project)

woah! I don’t want any environments in the first place. How do I exit it???
Also, I just updated Julia by downloading the latest version from the site, installing it in my software folder, updating the executable path in VSCode and adding Julia to path. Still not working

I’d suggest down-grading to the last release of the extension, not the pre-release (there’s a bug in there that messes up the environment path, as you can tell by the superfluous " in there).

how to I click it? I can’t! I can only click the environment thingy which opens the command pannel like thing, asking me to choose another folder (another environment) but again, I just wanna run the plain old Julia, which gives syntax highlighting, suggestions and autocompletion while working in VScode how do I do it??? pleaseee helpppppppp

Go to Output and select Julia Language Server in the dropdown:

[ Info: Precompiling VSCodeServer [9f5989ce-84fe-42d4-91ec-6a7a8d53ed0f]

why does it say that?? I don’t want an environment. How do I exit??? also, I did revert back to the released version, still doesn’t work

You’ll always be in an environment (though that might be the global one). Don’t worry about the “precompiling” message, that’s normal and expected.

ahhh task was selected earlier, as soon as I selected this the following message appears on the REPL:

The language client requires VS Code version ^1.82.0 but received version 1.80.1

but the precompiling message was not there until a few months ago… as far as I remember, then I would just run up the code and it would evaluate

Woah what? helpppp (I’m sorry I’m acting like a beginner… I mean I am … but idk… such a thing never happened before in like my past 2 years of programming. And I got an exam tomorrow so kinda stressed; just opened Julia to try an SDL package along with checking my answers for Matrix Multiplications xD and I get all this!)

What version of the extension are you on? It should be 1.61.2.

yes it is 1.61.2. I reckon it is some VSCode thing that I have toggled off unknowingly. What might be all the settings that I can mess up?

Okay, I figured the problem somehow was, as @pfitzseb pointed out, the status of Julia’s language server. It was stuck on Julia: Starting Language Server. I reverted to a previous release (v1.60.2) after a fresh install of both Julia and VScode (idk if that was even necessary) but yeah, that seemed to fix it.

Build and Test Docs

I have no idea why Julia’s build and test show ‘failing’ though.