Am I too stupid to use the Julia vscode plugin?

vscode
#1

I just installed a fresh vscode. Afterwards I installed the julia extension.

Now, I create a new empty Julia file text.jl and start typing:

vscode

No autocompletion. Even when triggered by CTRL + SPACE it just says “No suggestions.”.

I was hoping for IntelliSense.

I can tell that something is working because I can, for example, start the integrated Julia REPL and evalute code from the editor with CTRL + ENTER.

Am I doing something wrong?

(I’m on Windows 10.)

1 Like

#2
2 Likes

#3

I see, that’s unfortunate. Thanks for pointing out the issue though!

0 Likes

#4

weird, im using julia 1.1 on VScode and windows 10 and it looks fine

0 Likes

#5

There a few things that can fail: it might help to open vscode’s output pane and find the output for the Julia language server. In my case I found a bug that was easy to work around and got the language server up and running on 1.1 pretty quickly after that.

0 Likes

#6

Unfortunately, the julia Language Server output seems to contain only a single line:

[ Info: Started symbol server
0 Likes

#7

Indexing all packages can take really long the first time you start the symbol server, so maybe it’s just taking longer than you waited?

1 Like

#8

Thanks for the hint. I’ll let it run in the background over night and check again tomorrow morning.

0 Likes

#9

Unfortunately, I still only see the info message above. No autocompletion.

0 Likes

#10

If you solved this issue, mind submitting a PR?

0 Likes

#11

Oddly enough, I did not encounter this problem. Everything works fine for me in v1.1. Interesting…

0 Likes

#12

@crstnbr, is it that you can get no completion, or just no completion for particular symbols? I know there is this issue and this one which make the autocompletion of limited usefulness.

0 Likes

#13

It didn’t work for anything I tried (symbols, Base methods, etc.).

0 Likes

#14

FYI: The github issue mentioned above was closed because a SymbolServer.jl PR was merged. Maybe things will start working soon.

0 Likes