Julia 1.5 on Windows Terminal

I tried to use Julia 1.5 on Windows Terminal. I put the following entry to settings.json.

"commandline": "powershell.exe C:\\Users\\myname\\AppData\\Local\\Programs\\Julia 1.5.0\\bin\\julia.exe",

It didn’t work because of a space in the path. I knew it was introduced in https://github.com/JuliaLang/julia/issues/35720, and will be removed in 1.6. I have tried some options suggested in the Issue, but none of them worked.

  • "commandline": "powershell.exe \"C:\\Users\\myname\\AppData\\Local\\Programs\\Julia 1.5.0\\bin\\julia.exe\"",
  • "commandline": "powershell.exe C:\\Users\\myname\\AppData\\Local\\Programs\\\"Julia 1.5.0\"\\bin\\julia.exe",

Does anybody have any suggestion? It is not a Julia issue, but it is useful for others who may be in trouble.

I’ve put the folder to the PATH environment variable, then just used:

    "name": "Julia",
    "tabTitle": "Julia",
    "commandline": "julia.exe",

in my terminal config. Just checked it, works fine.

1 Like

remove the powershell.exe, it isn’t needed. Just e.g.:

                "name": "Julia 1.5.0",
                "commandline": "C:\\Users\\myname\\AppData\\Local\\Programs\\Julia 1.5.0\\julia.exe"",
                "hidden": false,
                "icon": "c:\\Users\\myname\\Documents\\julia_2.ico"

Of course, for the icon to work, you have to extract it first from the .exe and save it in the path you like.

1 Like

@cserteGT3 Thank you for your reply. Yes, it works well!

@oheil I didn’t notice this simple solution. I am going to take it this time. Thank you!

1 Like