Issues updating to Julia 1.3.1

I had been running JuliaPro 1.2 in Atom 1.40.1 x64. I wanted to update to Julia 1.3 because I’m under the impression that it has more powerful multithreading.

I downloaded julia and installed the Windows 64-bit exe from the downloads page, and I added a path variable according to the instructions.

I can get it to run from the julia commmand window, but when I try typing “julia” into the normal command, it tells me

'julia' is not recognized as an internal or external command,
operable program or batch file.

This isn’t a big issue, as I am working in Atom, but it is something I would like to understand and fix because I want to learn about system path variables.

In Atom, when I went to run julia, it ran JuliaPro 1.2, as it always has before. I tried changing the settings in Atom to run the new julia 1.3 by linking to it’s installation directory \bin\julia.exe. Now when I run julia in Atom, it does tell me it’s using “Version 1.3.1,” but when I try to execute lines in my old project files, it tells me I need to install the TokenManager package. So I try to do that, but it says,

The following package names could not be resolved:
* TokenManager (not found in project, manifest or registry)
Please specify by known ‘name=uuid’.

and a pop up window tells me

LoadError: ArgumentError: Package TokenManager not found in current path:
- Run `import Pkg; Pkg.add("TokenManager")` to install the TokenManager package.
in expression starting at C:\JuliaPro-1.2.0-1\.atom\juno_startup.jl:1
require(::Module, ::Symbol) at loading.jl:887
include at boot.jl:328 [inlined]
include_relative(::Module, ::String) at loading.jl:1105
include(::Module, ::String) at Base.jl:31
include(::String) at client.jl:424
(::var"#5#8")(::String) at boot_repl.jl:60
handlemsg(::String, ::String) at comm.jl:164
(::Atom.var"#19#21"{Array{Any,1}})() at task.jl:333

After this, I tried updating Atom to 1.43.0, updated all my packages, and had the uber-juno package in atom reinstall all of the julia things (like REPL).

I still get an issue whenever I try to start julia in atom that it’s missing the Token Manager. It doesn’t seem to make anything crash though. I can close this popup window and still run lines of code. But why does it say it’s looking in expressions in JuliaPro-1.2.0-1?

It also seems that all of my packages need to be reinstalled since updating to Julia 1.3.1. Is this right or did I do something wrong with installation?


JuliaPro hasn’t been released with Julia 1.3. We’re working on it, it’s turned out to be more difficult than expected. The source of your issues is that JuliaPro has a few dependencies that make it difficult for it to work with a vanilla Julia download … you need to download the entire bundle together.

If you can, I’d suggest waiting for JuliaPro 1.3, which should be out soon. The good news is that these extra dependencies for JuliaPro will go way in JuliaPro 1.3, and subsequent releases of JuliaPro will be much easier.

1 Like

I am not familiar with Windows, but I think it is an issue with the path. Or maybe you need julia.exe?

Try executing with the full path,