Issue with LLVM.jl with non-ascii user names on Windows

Dear all,
I have Installed the package DifferentialEquations.
However, when I run using DifferentialEquations an enormous problem apperars: see below.


Failed to precompile DifferentialEquations [0c46a032-eb83-5123-abaf-570d42b7fbaa] to C:\Users\Usuário\.julia\compiled\v1.5\DifferentialEquations\UQdwS_cfyDf.ji.
in  at base\task.jl:356
in macro expansion at Atom\MxsDb\src\eval.jl:41 
in invokelatest at base\essentials.jl:709
in #invokelatest#1 at base\essentials.jl:710
in eval at Atom\MxsDb\src\eval.jl:114
in macro expansion at Media\ItEPc\src\dynamic.jl:24 
in macro expansion at Atom\MxsDb\src\eval.jl:117 
in hideprompt at Atom\MxsDb\src\repl.jl:127
in #200 at Atom\MxsDb\src\eval.jl:118 
in with_logger at base\logging.jl:514 
in  at Atom\MxsDb\src\eval.jl:119
in withpath at Atom\MxsDb\src\eval.jl:9
in withpath at CodeTools\VsjEq\src\utils.jl:30
in  at Atom\MxsDb\src\eval.jl:121
in include_string at Atom\MxsDb\src\utils.jl:286


Anyone can help me please?

Try ]build DifferentialEquations again? Looks like it just cut out while downloading one of the dlls.

Nothing yet…


The error is the same.
Could you help me please?

These are the packages on my system:

Status `C:\Users\Usuário\.julia\environments\JuliaPro_v1.5.4-1\Project.toml`
  [c52e3926] Atom v0.12.30 ⚲
  [0c46a032] DifferentialEquations v6.16.0
  [4b11ee91] Gaston v1.0.4
  [2e9cd046] Gurobi v0.9.12
  [7073ff75] IJulia v1.23.2
  [4076af6c] JuMP v0.21.7
  [e5e0dc1b] Juno v0.8.4 ⚲
  [2fda8390] LsqFit v0.12.0
  [4722fa14] PkgAuthentication v1.1.1
  [91a5bcdd] Plots v1.12.0
  [44d3d7a6] Weave v0.10.7
  [9a3f8284] Random
  [10745b16] Statistics

I have re-installed the JuliaPro but not solved the problem.

Try using a standard Julia installation.

I have used the standard Julia but no yet…

Can you share the output of that?

Is the same above…see the figures.
I don’t know to solve this.

That’s still JuliaPro instead of from the downloads page.

Not sure why it can’t load LLVM.
I assume LLVM.jl doesn’t work either; what happens if you try

using Pkg; Pkg.add("LLVM")
using LLVM

He install LLVM, as can you see below with several warning messagens:

Next, when I load using LLVM an error occurs:

Why this happens?
Can be the name of my folders: “usuário”??

Someone else reported recently that Chinese characters in the path cause this to fail on Windows, so it might be the case that unicode (e.g. “á” in “usuário”) is the problem.

1 Like

Those errors are still all showing JuliaPro. Please show what it looks like without JuliaPro.

Now using Julia only. The errors are the same.

Look the errors: using Julia only

Looks like it’s a @Elrod thing then.

It’s not VectorizationBase specific. Any library that wants to use LLVM (such as LLVM.jl) throws the same error.
One person reports non-ascii user names as the cause of the problem:

I’d suggest trying to create a new ascii username and seeing if the problem persists.

1 Like

Oh, peculiar.

You suggest I create a new folder to my user?
I this situation, I will need to format my computer, because it does not allow you to change the name Usuário in the path.
A similar thing happens in the ```gr()´´´ package.