Installation of Julia on SCO OpenServer

I downloaded the Unix binary, gunzip, tar xvf, and chmod to execute. No errors, it just doesn’t do anything. What did I miss?

Which library did you download?

A quick search about “SCO OpenServer” is that it is is a FreeBSD derivative. Did you download the FreeBSD binaries for Julia? @ararslan might be able to assist you on FreeBSD related matters.

It looks like I got the Linux version, let me try FreeBSD…

===>I was in /usr/bin when I created my link as follows:

ln -s /u/julia/julia-1.7.3/bin/julia julia

===>Then I checked permissions ( “l” in SCO OpenServer is the same as “ls -l”)

l julia

-rwxr-xr-x 1 1001 1001 16104 May 17 23:28 julia@
===>the link picked up the permissions that I wanted so I tried it:

julia

===>and I got:
julia: syntax error at line 1: `(’ unexpected

===>So I tried to set the path

export PATH=“$PATH:/u/julia/julia-1.7.3/bin”

===>and I got:
PATH=/bin:/etc:/usr/bin:/tcb/bin:/usr/sbin:/sbin:/u/julia/julia-1.7.3/bin: is not an identifier

Before we think about the symlink and figure out what shell you are running, what happens when you just execute /u/julia/julia-1.7.3/bin/julia

SHELL=/bin/sh
===> and

/u/julia/julia-1.7.3/bin/julia

/u/julia/julia-1.7.3/bin/julia: syntax error at line 1: `(’ unexpected

I think it’s called a “C shell”

Something seems wrong with the environment. Can you run other executables?

Maybe you should try building julia from source.

Frankly, I highly doubt that anything will work out-of-the-box on a proprietary system no one has access to: for Julia that’s a totally unknown system, anything related with binary libraries won’t definitely work at all. Unless @Jim is willing to invest much time on porting Julia to this platform, but don’t expect much help on such a niche system.

1 Like

That seems to be a strange question, who would use an operating system that you couldn’t run executables on? maybe I don’t understand your question. Is perl an executable, for instance?

I’m willing… even willing to pay for help…

I’ll bet once we get it done there are going to be a bunch of people that want it

Which version of OpenServer are you on?

6.0.0 on several and 6.0.0 Definitive on one

even have 5.0.7 on one

Ah ok, so that’s well before they switched to FreeBSD-based, so the FreeBSD binaries shouldn’t be expected to work either… Building from source is probably the only option, and would presumably require building a bunch of dependencies from source too (like the right version of LLVM, etc.). I know I wouldn’t be able to do it, but maybe you can.

Does building from source require a C compiler?

For building Julia from source I expect you’d need both a C compiler and a C++ compiler given the repo has both (I actually haven’t done it myself before though). For LLVM definitely C++. For BLAS, if you have to build that from source too you might also need a Fortran compiler

I would be happy with just the julia compiler to work

I’m trying to figure out if there is a shell misconfiguration that may affect other binaries than Julia.

I was hoping the basis of SCO OpenServer on FreeBSD would allow for some binary compatibility.

I think Mose is right though and there is likely a fundamental incompatibility with the binaries, and it might be difficult to build Julia and its depedencies.

If you would like paid support, I suggest contacting Julia Computing:
https://juliacomputing.com/products/juliasure/