IJulia not working on 1.0.0

Continuing the discussion from Julia 1.0 released:

FYI IJulia isn’t working for me on 1.0.0. I always see this:
image

The cell appears busy ( * to the left of the cell ), but the kernel appears idle ( empty circle to the right of the kernel, Julia 1.0.0).

This is from jupyter-lab, but I get the exact same behavior if I run

using IJulia
notebook()

Here’s my verisoninfo()

julia> versioninfo()
Julia Version 1.0.0
Commit 5d4eaca0c9 (2018-08-08 20:58 UTC)
Platform Info:
  OS: Windows (x86_64-w64-mingw32)
  CPU: Intel(R) Xeon(R) CPU E5-1650 v4 @ 3.60GHz
  WORD_SIZE: 64
  LIBM: libopenlibm
  LLVM: libLLVM-6.0.0 (ORCJIT, broadwell)

Is anyone else seeing this behavior?

2 Likes

I have the same problem on Windows, but it works on Linux(at least on 0.7)

1 Like
1 Like

@aaowens That’s good to know re: Windows vs. Linux. There’s no verbosity keyword for IJulia.notebook so I’m unsure of the next step to debug this.

@mzaffalon Thank you for the info.

As a side-note, with WSL (Windows Subsystem for Linux), my temporary solution may be to just install anaconda/Julia 1.0 via WSL and run jupyter lab from the linux side.

I was hoping that would be solution as well. Have you gone through with it? Any success? I’ve setup WSL with conda, R, and Julia. Both python and R seem to run just fine through WSL, however, IJula still will not work.

I gave it a quick try and ran in to a different issue. I’ve reverted to just using 0.6.4 until I get this (and a different issue w/ PlotlyJS.jl) sorted out on 0.7 / 1.0.

running into the same situation, Ijulia kernel 1.0 does not work in Jupyter Notebook

Any suggestions? Thanks.

Tried;

(v1.0) pkg> add IJulia
ENV["IJULIA_DEBUG"] = true
(v1.0) pkg> dev IJulia
(v1.0) pkg> build IJulia

Works fine now.

Worked for sometime. Then back to square one.

Same to me. It works for 5 minutes then after it hangs indefinitely.