How to use sysimage in jupyter?

How to use custom julia sysimage in jupyter?

1 Like

You’ll have to install a kernel with the --sysimage=path/to/sysimage flag. See the relevant section of the IJulia README.

2 Likes

This worked with jupyter notebook but did not with jupyterlab and nteract.

If you want help with those, you’ll need to be more specific about what you tried and what didn’t work. At a guess, I’d check to make sure you’re using the same installation of jupyter for IJulia as you’re using for nteract/jupyterlab.

For JupyterLab, you should also be able to switch between installed kernels: https://medium.com/@jeremy.from.earth/multiple-python-kernels-for-jupyter-lab-with-conda-c67e50de3aa3

In all cases, it is possible to run sysimage, but in jupyterlab / nteract it is not possible to run a cell.

There is no error message, the only message that appears is:
"Adapting from protocol version 5.0 (kernel eaa6d4a2-07e6-46d1-a5f0-c4ebb2765e4a) to 5.3 (client).
"
I believe it is a bug in jupyterlab, I will try to update it.

After updat and build jupyterlab it worked. Thank you! :slight_smile:

1 Like