How to get 'stable' URL for documentation?

According to the documentation for Documenter.jl:

  • Documentation built for a tag vX.Y.Z will be stored in a folder vX.Y.Z .
  • Documentation built from the devbranch branch ( master by default) is stored in a folder determined by the devurl keyword to deploydocs ( dev by default).

Can somebody please explain how to build documentation for a specific tagged version?

I’ve built documentation for a package which has a release version v0.1.1, but because the docs come from the ‘master’ branch on git, I can only see the dev URL on the github pages hosted site…
I’ve seen that other packages have folders marked with the version number on the ‘gh-pages’ branch where the tagged documentation is pulled from, but I don’t understand how I can create such a folder :man_shrugging:t2:.

Any help would be much appreciated :pray:t5:

Doesn’t the “Fixing broken release deployments” in your link work well?

Your documentation workflow is not running for tags as far as I can tell. My hunch is that the culprit is the GITHUB_TOKEN permission issue with TagBot, although I do not see anything actually wrong with your setup.

1 Like

Here is a step by step that might be helpful:Publish Docs · JuliaNotes.jl

4 Likes

@lmiq, thanks and btw, who is Christopher in your notes?

1 Like

So I managed to resolve the issue…

(Please excuse my crude amateur explanation :roll_eyes:)
I built the docs for this package long before registering the package in the general registry.
So in my local git GUI, the tagged versions of the package only appear as tagged versions since registering.
I went back to the last commit with an associated tag, and re-pushed it to the master branch.
That seemed to trigger the documentation to create the new version folder in the gh-pages branch, as well as the stable folder.

This is probably the same/similar process as suggested by @lmiq.

Is it me or does this seem to be a somewhat common issue?
There’s probably a simple reason why I couldn’t get it to work in the first place (most likely something stupid I did), but as @mortenpi has clarified, the workflow seems ok…
:man_shrugging:t2:

Thanks for the support! :slightly_smiling_face: :innocent: