How to get Julia work for the first time?

I am trying to learn Julia by following steps in

I followed the basic command for Plots, but got an error message. I searched for that message, and followed suggested solution. However, I still get an error:

Can I get some help to get started?

Try it without the gr(fmt=:png) line. Otherwise, try Pkg.add("GR")


The system doesn’t find 7z.ex. Starting with Julia 1.3.x, this program is located in the libexec directory. You should update GR (] up GR) and rebuild again - that should help.

Sorry you are having trouble. That shouldn’t be necessary. @arnavsood are things up and running correctly on Julia 1.3 with the existing manifest/package, or do we need to push a bumped package and manifest for 1.3 support?

Regardless @DShiu Can you try the following: In that notebook (where the package/manifest is already there) try to go

] instantiate; precompile

and see if that works. It could be that you don’t have the consistent set of packages installed…

I tried it without the gr(fmt=:png), but got the same error. Then I tried

I do find 7z.exe in the directory you mentioned. I tried to do ] up GR, and got the following

I tried ] instantiate; precompile, and got a long list of errors. Some of them say I need to build something, I tried but got other error messages :frowning:

Smells like a 1.3 vs 1.2 package issue. So sorry… You can try 1.2 temporarily, but there is a decent chance you would need to delete your .julia afterwards and retry the instantiate. Regardless, tomorrow we will investigate bumping package versions

I see. I can wait and start my journal after the investigation. Please let me know if you resolve the issue. Thanks!

Can you post on and we can discuss steps there? Thanks.

What happens is that in Julia 1.3, the 7zip executable got moved from bin to libexec, go to the libexec folder, and copy the 7zip files in bin

I copied 7z.dll and 7z.exe to bin. However, the problems are still there.

will do