Missing 7z.exe in Julia-1.3.0-rc3

Compared to previous Julia versions it looks like, that 7z.exe file in %JULIA_HOME%/bin is missing (right after a fresh installation).

This issue has been detected when adding JLD2 package.

add JLD2
  Updating registry at `C:\Users\mike\.julia\registries\General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`
 Resolving package versions...
ERROR: No compression engines found. We looked for: c:\Data\mike\Programs\Julia-1.3.0-rc3\bin\7z.exe, 7z, tar, busybox. Install one and ensure it is available on
the path.

Since 7z.exe has been packed with Julia potentially not only by chance, referencing an system wide installed 7z binary by extending the path variable is assumed not to be the best approach.

It is known.

Thanks for the reference to the existing issue and your support is really appreciated.

Just a further comment to that topic.

Interestingly the problem did occur on a fresh installation of Julia-1.3.0-rc3 on Windows 7 professional 64bit. Yes there have been some older versions of Julia available on that machine, but rc3 has been installed first time and right after that this behavior occured when adding JLD2.

With a test on another machine with Windows 10 Home 64bit, with previously only Julia 1.2 installed in a completely different path, no problems at all arised. Even though, there is no 7z.exe file in the %JULIA_HOME%\bin directory. And there is no other 7z.exe file on that machine, other than the one in the Julia 1.2 bin directory. System and user path variables do both not reference that bin directory. So no 7z.exe in the search path available.

Julia 1.2 installation delivers a 7z.exe file in its bin directory. Julia 1.3 RC 3 installation does deliver a 7z.exe in its bin directory. The same as on Windows 7. Regarding this topic, installation on both OS types seam to deliver equivalent files on the disk. No 7z.exe file on both machines. But the behaviour when adding JLD2 was different.

Not clear to me what the dependencies really are. Is there also a OS dependency? I don’t know?

I hit this error on Windows as well. I already had Julia 1.2 installed which did have 7z.exe in its directory. When I installed Julia 1.3 rc3 and tried to install JLD2, I hit this issue. I could see that there was no 7z.exe in the 1.3 directory although the 7z dll was there. The workaround was to copy 7z.exe from the 1.2\bin directory into the 1.3 one.

Update: there is still no 7z.exe in the 1.3\bin directory but package installs now work. Maybe it is picking the one in the 1.2 directory.

Same “discussion” here. IMO 7z.exe and 7z.dll should be in the same directory - no matter which one.

2 Likes
1 Like

Just had this problem with a fresh Windows 10 install of Julia 1.3.1 from the official downloads.